HiDPI display - PHPStorm, -dhidpi doesn't work

Answered

Hello,

I have a 4K display running on Windows 10, and I'm having trouble finding how I can scale the text and menu items so everything is a little more legible. I have tried adding -dhidpi=true to phpstorm.exe.vmoptions and phpstorm64.exe.vmoptions without luck.

Thank you.

4 comments
Comment actions Permalink

Hello, IDE should use system settings to adjust scale accordingly.

What PhpStorm version are you running? Could you please attach a screenshot of how does it look for you and screenshot of File | Settings | Editor | Colors & Fonts | Font ?

0
Comment actions Permalink

Hello,

It's still far too small even if PHPStorm uses the operating system's settings to scale properly. I have Windows 10 UI scaling set to 175% (the default is 150% - so it's higher than it usually is).

I have attached several screenshots as requested.

Thanks.

0
Comment actions Permalink

Hello,

I've figured out what the cause is.

Override default fonts by (not recommended) was selected in File | Settings | Appearance & Behavior | Appearance. I've deselected this now and all the font sizes are as they should be.

1
Comment actions Permalink

Thanks Ben, your comment was very helpfull!

0

Please sign in to leave a comment.