Problem getting IDEA to read an enterprise plugin repository.

Answered

Below I have copied the error that I receive when entering a new repository into PyCharm (the same error is given in any IDEA IDE). This plugin installs from disk and works correctly, I am simply having a problem with hosting.

 

updatePlugins.xml:

<plugins>
    <plugin id="MyPlugin" url="https://www.auburn.edu/~ski0005/TDD/edu.auburn.eng.csse.tdd_jb.zip" version="1.0"/>
</plugins>

 

Error:

List of plugins was not loaded for following hosts:
https://www.auburn.edu/~ski0005/TDD/

Due to the following errors:
'org.xml.sax.SAXParseException; lineNumber 1; columnNumber: 55; White spaces are required between publicId and systemId.' for 'https://www.auburn.edu/~ski0005/TDD/'

1 comment
Comment actions Permalink

Please change repository in "Custom Plugin Repositories" to https://www.auburn.edu/~ski0005/TDD/updatePlugins.xml. You can check that everything works correct by pressing "Check Now".

0

Please sign in to leave a comment.