Cannot show node_modules folder in Project tool window

Answered

Problem: Folder node_modules is not visible in the Project tool window, even though the Show Excluded Folders option is checked.

Already checked on:

  • In Preferences|Directories, in left column, node_modules folder is listed as Excluded, but,
  • cannot change status in right column, because folder doesn't appear there (see image).
  • No option to Mark Directory As...
  • Makes no difference if Preferences|Languages|JavaScript|Libraries has node_modules enabled or not.

What to do?

11 comments
Comment actions Permalink

Hi there,

Do you have Vue.js support plugin installed by any chance? Remove it -- it hides node_modules folder from Project View.

if it's not caused by that plugin -- have a look at this thread then: https://intellij-support.jetbrains.com/hc/en-us/community/posts/208376385-How-to-unexclude-node-modules-in-2016-2-2-

4
Comment actions Permalink

Vue.js was the problem. Thanks!

0
Comment actions Permalink

Props Andriy!  That was exactly the culprit.

0
Comment actions Permalink

Hi!

sadly i have the same problem (since a long time). On my system i found no way to show the node_modules folder at all. It is either excluded nor i have installed the Vue plugin. i have attached two images, showing a screen of IntelliJ Projectview and a screen right from the filesystem. Any ideas?



0
Comment actions Permalink

I just tried, what happens if i run IntelliJ under a new macOS-User-Account with fresh settings. And there the node_modules folder is displayed.

0
Comment actions Permalink

@Matthias Schulz

>On my system i found no way to show the node_modules folder at all. It is either excluded nor i have installed the Vue plugin.

Does it behave the same with brand new projects (using the same old user profile)?

You may try backing up and deleting existing IDE-wide settings and configure IDE from scratch (well, most of the config files could be then recovered back from a backup -- as long as you will not restore "problematic" file as well; but stuff like Keymap, Code Style, Color Scheme, External Tools should be restored with no issues)

Directories used by the IDE to store settings, caches, plugins and logs

0
Comment actions Permalink

Yes - it behave the same with every new project with my current profile. I'll try to reset all setting. Thanks you so far Andriy.

0
Comment actions Permalink

@Matthias Schulz @Andriy Bazanov 

I had the same problem to display node_modules even without having Vue plugin, as many others said that it could hide the node_modules folder.

NOTE: YOU DON'T NEED to reset your IDE-wide settings and restore it, as you may lose your preferences like ColorScheme, Keymaps and so on. Instead check whether the node_modules folder is ignored or not in File Types.

I've spent many hours to figure that out.

TO FIX: In my case, remove node_modules from the list of ignored files it will solve the question. Hope it helps others Googlers facing the same problem, which is not an issue with PHPStorm.

1
Comment actions Permalink

@Adriano Rosa THX – that solved my problem as well. 

1
Comment actions Permalink

I finally deleted .idea folder and reopened. node_modules were visible, but then over the period of the last three days IntelliJ has been freezing up (im guessing indexing this huge codebase). I just need to edit code, and debugging is REALLY nice but useless if the IDE is frozen. 

I am an all product subscription customer, I love Jet Brains but can't justify spending money on something that slows me down.  :(

0
Comment actions Permalink

but then over the period of the last three days IntelliJ has been freezing up (im guessing indexing this huge codebase). I just need to edit code, and debugging is REALLY nice but useless if the IDE is frozen.

To understand what's happening there for you, we need to take a look at the logs. Please wait for it to freeze again, restart the IDE, collect the logs with Help | Compress Logs and submit the archive within a support ticket: https://intellij-support.jetbrains.com/hc/en-us

0

Please sign in to leave a comment.