Vue.js Method shortands are not supported by current Javascript version

Hi.

I'm using PHPStorm for Laravel projects and testing use Vue.js.

When try my first test, get error on image attached.

After, install Vue.js plugin and restart PHPStorm, and work fine. But after install Laravel plugin error.

Try disable plugin Laravel, and restart, but not work.

https://dropbox.tamainut.net/owncloud/s/mfVLzkV9Il19e3o

Any ideas?

 

 

4 comments
Avatar
Vladimir Luchansky
Comment actions Permalink

Hello,

Did you try to check and change the JavaScript version in File | Settings | Languages & Frameworks | JavaScript?

0
Comment actions Permalink

 

Hi

I go to preferences (for project) and test all Javascripts a EMA versions...

 

And nothing

 

 

0
Comment actions Permalink

This might be a part of an https://youtrack.jetbrains.com/issue/WI-32604 issue. 

Any chance to share a project? 

Please also try File > Invalidate Caches/Restart > Invalidate and Restart.

1
Comment actions Permalink

Hi, I had the same problem
in my case,i did this and fixed the problem.
From Settings->Languages & Frameworks->JavaScript , put JavaScript Language Version on ECMAScript 6 and hit OK.

1

Please sign in to leave a comment.