Values memory addresses do not show in debugger

When debugging code, the memory addresses of the values do not show up anymore. It used to work fine in versions, but in the last 3 (?) versions the addresses do not show up anymore.

I am using WAMP - PHP5.6, Xdebug, all debug functions seem to work fine. I work on Vagrant machines as well sometimes, and that has similar results. Debug works, but addresses not shown.

Win 10, PHPstorm 2016.2.1

Any advice on this?

3 comments
Comment actions Permalink

Hi there,

Checked in PhpStorm 2016.2.1 as well as 2016.3 EAP build (on Windows 7) using PHP 5.5.38, 5.6.28, 7.0.11 & 7.0.11 x64 -- all nts builds. Have tied with xdebug 2.4.0 as well as 2.4.1 -- all of them showed the same behaviour (no addresses).

Then I have tried the same with PHP 5.4.45 and xdebug 2.3.2 -- works fine. Tried PHP 5.6 & xdebug 2.3.2 -- works fine as well.

Apparently the address field was removed from xdebug response back in xdebug 2.4.0 RC2 (which was released back in December 2015 -- over 10 months ago -- https://xdebug.org/updates.php#x_2_4_0RC2 ).

Original xdebug ticket: https://bugs.xdebug.org/bug_view_page.php?bug_id=00001189

If you need that address info -- go back to using xdebug 2.3.x (2.3.3 is the latest version of that branch)

2
Comment actions Permalink

"Fixed for 2.4.0 (by removing the whole address nonsense in the first place)"

I found it very useful when checking for weird side-effects when cloning objects and such. Well, nothing Jetbrains can help, other then maybe hide the button when not available anymore. 

Thank you so much for diving into this, great!

Matthijs

0
Comment actions Permalink

I've created a ticket about this: https://youtrack.jetbrains.com/issue/WI-33581 -- watch it (star/vote/comment) to get notified on any progress.

1

Please sign in to leave a comment.