Debugging C++ with CLion 2016.2.3 on CentOS 6.8 fails

I'm attempting to debug a simple Hello World program with CLion 2016.2.3 on CentOS 6.8 and it fails. I tried CLion 2016.2.2 on CentOS 6.8 and it also fails when debugging.

CentOS 6.6 and CLion 2016.2.2 worked.

3 comments
Comment actions Permalink

Hi Joe. 

Sorry for the inconvenience. Please enable debug logging by entering `#com.jetbrains.cidr.execution.debugger` into Help | Configure Debug Log Settings, restart the IDE, reproduce the problem and send us idea.log (Help | Show Log in Finder) to clion-support at jetbrains.com. Do not forget to disable debug logging after that.

0
Comment actions Permalink

Turns out the latest QtCreator has a similar problem. I suspect it has to do with gdb 4.2's python support.

I sent the log.

0
Comment actions Permalink

For future reference, this behavior is apparently due to the tcsh shell being the default. Anna suggested a successful workaround, which is to add the following line to ~/.gdbinit:

set startup-with-shell off

Thanks to Anna for the superb support on this.

0

Please sign in to leave a comment.