Webstorm doesn't start

When Webstorm told me it ran out of memory I tried to increase xmx from 512 to 2048MB and selected Shotdown. As it stated that a restart was required for changes to take effect. Now Webstorm won't start anymore. when i try running the executable nothing happens.

The settings in "WebStorm.exe.vmoptions" does not seem to have changed, xmx is still at 512, so i don't understand what the problem is.

I'm using:

- Windows 8.1.

- Java 8 update 111 (build 1.8.0_111-b14) (32-bit)

- WebStorm 2016.2.3.

I have tried updating Webstorm to v2016.2.4, but the problem still persists.

11 comments

JVM can't allocate requested heap and thus fails to start. Oracle JVM requires a single chunk of continuous memory (more or less equal to Xmx parameter value) to initialize. On Windows systems 32-bit java can only allocate up to 2 Gb. And any libraries that inject themselves into process memory reduce this solid block, so usually the maximum heap it can actually reserve is 1.2-1.4 MB. 2048MB is just too much for it..
Please try reducing Xmx back to 750m, for example - does it work? It has to be done in ~\.WebStorm2016.2\webStorm.exe.vmoptions file, where ~ is your home folder, smth like C:/Users/Your.Name

2

Thank you, that fixed it, I was looking at the wrong "webStorm.exe.vmoptions" file.

I have another question: As far as I understand, installing 64-bit Java and running "webstorm64.exe" will take care of the "running out of memory" problems I experience from time to time. Is this the case, and if so, are there any reasons why I should not switch to webstorm 64? The reason I ask, is because the 32-bit webstorm version seems to be the default version when running webstorm after installation. I can't really see why anyone would want to work in the 32-bit version, with limited memory, when they can work without this problem in the 64-bit version. So that makes me wonder if there is some other reason why the 32 bit version seem to be preferred?

0

> As far as I understand, installing 64-bit Java and running "webstorm64.exe" will take care of the "running out of memory" problems I experience from time to time

64-bit java allows allocating more memory (you can reserve large heap for it). So, if reserved heap is large enough for your project to fit, then yes - using 64-bit java will take care of outOfMemory issues

 

>Is this the case, and if so, are there any reasons why I should not switch to webstorm 64? 

32-bit java runs faster and consumes less memory... Please see http://www.oracle.com/technetwork/java/hotspotfaq-138619.html#64bit_performance. So using 32-bit is recommended unless you have a very large project and face outOfMemory issues. 
In our experience IDE lags significantly more with larger heap sizes due to GC pauses so setting larger heap size temporarily hides some real performance problem / memory leak. So we do not advise significant changes for heap size allocated but recommend to report issues to us

0

Exactly the same problem I am experiencing right now. I reduced the xmx value to 512 MB - nothing happens, WebStorm doesn't start. Reinstalling didn't help. I cannot believe JetBrains delivers a product like that, I was about to buy it.

0

what file did you change namely? Please thread the thread above - ability to reserve larger heaps is not WebStorm issue

0

I changed the Xmx value to 2048 in webstorm.exe.vmoptions (32 bit), then back to 512. WebStorms doesn't start anymore.

0

Please read the thread once more. You must have changed the wrong webstorm.exe.vmoptions file (the one in bin/ folder). Please see what `~\.WebStorm2016.3\webStorm.exe.vmoptions` file looks like.

0

You are right, I changed it in bin/ folder, but I dont' have a ~\.WebStorm2016.3 folder, there is only a "WebStormProjects" folder. After changing back the Xmx value in bin/ on another machine, WebStorm starts again. I check again on the machine where I had the problem first.

0

>but I dont' have a ~\.WebStorm2016.3 folder, there is only a "WebStormProjects" folder

 

You do have it - it's a folder where WebStorm saves its configuration and caches, and for sure it's there.

To check if your have vmoptions file in your WebStorm configuration directory, try Help | Edit Custom VM Options. If the file is there, WebStorm will open it, and will suggest to create it otherwise. If it exists, you can change the XMX value there

0

You are right, it's there, starting with a dot, I think I need glasses soon. But the options file is not contained. That's why switching the Xmx value back (in bin\) worked, I guess.

PC1: options file in bin\ and ~\.WebStorms2016.3 - switching Xmx value back in ~\.WebStorms2016.3 works.
PC2: options file in bin\ - switching Xmx value in bin\ works.

Thanks for your support!

0

Conclusion: The files are not created automatically in folder ~\.IntelliJIdea2016.3. You should edit a copy of the file (from ...\JetBrains\IntelliJIdea2016.3\bin). The reason is that app bundle is signed and you should not modify any files inside the bundle; therefore, you need to make a copy in IDE preferences folder, which you will modify. This hint is from https://www.jetbrains.com/help/webstorm/2016.1/tuning-webstorm.html

0

Please sign in to leave a comment.