Upgrading IntelliJ IDEA after Sierra Upgrade: does not have write access to /private/var


Trying to upgrade Intellij IDEA from 2016.2 to 2016.2.5 on OSX Sierra and I am getting this error:

IDEA does not have write access to /private/var/folders/_q/7md3pcy10x9cxjdt9nzxjvdr0000gn/T/AppTranslocation/97E0DA6A-73B2-4439-91AE-F7DD0353F063/d/IntelliJ IDEA.app/Contents

I can't modify the permissions of that folder because it is read-only. I've tried chown and chmod as root, neither of which work. I know that Sierra changed the way this part of the file system works but I have no idea how to get around this issue.

Official comment

Please check the workaround described here: http://stackoverflow.com/a/41383566/104891.

I was just trying to let it update via patch.


Not sure why this folder is referenced, I don't recall similar reports from any other users.

Update via the dmg and if it happens again, submit a bug at https://youtrack.jetbrains.com/issues/IDEA with idea.log and updater.log.


Thanks. I'll give that a shot later this afternoon.


I just tried updating with same result, and don't see why you haven't gotten similar reports from other users since every sierra (10.12.1) user should have the same problem: that file system is read only and you can't change the perms. It has to do with Apple steering all software through their gates. So--has apple given you guys a work around?


> every sierra (10.12.1) user should have the same problem

Our testers using 10.12.1 were not able to reproduce the problem, unfortunately.

So, it appears that this problem affects a small amount of users, otherwise we'd be flooded with these reports already. So far we have just 2 reports.

> that file system is read only and you can't change the perms

Could you please provide a source that would confirm it? I found here that DARWIN_USER_TEMP_DIR folder uses 0700 permissions, so the process should be able to read, write and delete the files there. Why would anyone make a temp folder read-only? It makes no sense.

Screenshots from our test machine where the update has worked without problems:


Hi Serge, and thanks for your response. The actual directory in 'AppTranslocation' could be unique to each machine/install. My file is: 

/private/var/folders/73/b_h0rvxx64z6_124d1q1qlc00000gs/T/AppTranslocation/F334213A-CE01-400D-855E-1C3DAA1B4E5C/d/IntelliJ IDEA-2016.2.4.app/Contents

I have write permission to the directory (755), but when I try to create a file (e.g., touch this), I am told that the file system containing this directory (i.e. /private ) is mounted read only.

As Gregg did, I tried updating as a patch through Intellij, not as a dmg. Checking with apple, seems their preferred app installation now is as dmg. That way, apple controls the process, and so might be for now the only solution. I just upgraded to 10.12.1 this week so I don't think there are too many others out there yet (?).

There is a discussion on stackoverflow on this, also very recent: Q: Upgrading IntelliJ IDEA after Sierra Upgrade: does not have write access to /private/var




It's the same post from Gregg on SO. Patch update works fine on our test machines with Sierra 10.12.1, not sure why this issue occurs for some users.


Oh, just noticed that the stackoverflow Q was submitted by Gregg, So could be small world after all. Anyway, I'll just sit tight for now.

Thanks. -D


I think why you night not be able to reproduce is that you have to have installed 2016.2 on a non-Sierra machine, run it a bit so those files get created, then upgrade to Sierra, which modifies that file system post having IntelliJ installed; then try patching IDEA. Installing it on Sierra to begin with, IntelliJ probably can't write there anyway.

I still haven't tried just downloading the latest DMG but I will soon and report back.


Nice catch, Gregg, that could very well be the deal. If verified (which neither you nor I can do at this point: I am not willing to experiment, unmount and remount system file systems as writable...), that means it really is an apple problem, and would apply to any s/w installed then patched in the same order, all s/w other than through their app store. -D



A bit late to the game as I've been ignoring this annoying issue for well over a month, but I confirm having the same issue:

I don't recall the date I received this InteliJ update, I can however say that I tend to update MacOS as soon as updates are available.

I downloaded the latest Community DMG from https://www.jetbrains.com/idea/download/index.html, and simply replaced my app... we'll see if I encounter the issue upon the next update.

On a side note, I also use PhpStorm ... and that has no issues upgrading, despite the many updates and OS upgrades/updates.




I had the same problem guys. I think IntelliJ was installed as another user and found that changing the ownership on the IntelliJ IDEA application to myself (must be an administrator) and group to my group which was called conveniently "admin". Also make sure permissions are set to 755. All this must be performed recursively throughout the IntelliJ IDEA application folder. This is my first time posting help for anything, ever, hope it helps :)


I have been living with the problem myself for a couple of months now. I did upgrade to Sierra after installing 2016.3 as others have indicated and am experiencing the same problem.

I have gotten to the point where I am annoyed enough to do something about it, has progress been made around solving this?


having the same problem after upgrading just now to macSierra --- I hope the issue will not manifest itself each time we have to upgrade idea :|


Had the same annoying problem

Solved it by 

cd to intellij Content directory

sudo chmod -R 755 .



I can confirm I am having the same problem. This is happening on at least six machines in our work environment, all Sierra. My message is:

IDEA does not have write access to /private/var/folders/b_/4zyvfd856dnckrpxs98kvfbh0000gn/T/AppTranslocation/FD591E8E-F42C-4DA6-A97F-2B2EAC6D24AF/d/IntelliJ IDEA CE.app/Contents. Please run it by a privileged user to update

This happened with fresh installs from the dmg on machines without any prior installation of IntelliJ. It also happened on machines that did have a prior installation of IntelliJ. Most of the machines were upgraded to Sierra before IntelliJ was even installed.

I tried the chmod trick on the Content directory and that did nothing, unfortunately.


I've just encountered something very similar while testing jar updates with my app AuctionSieve.

The problem occurs when you run the app from the Downloads folder and try to do the update - it gets FileNotFoundExceptions because the entire folder macOS creates under /private/var/folders is a read-only filesystem. You can't change the permissions of the files at all.

Moving the app from the Downloads folder to the Applications folder solved the problem!

I suspect the small percentage of people that this effects have not copied IntelliJ to the Applications folder.


I'm getting exactly this issue. I have a new MBP, installed everything from scratch, IntelliJ is in the Application folder, every time I get the upgrade message I get this message and have to download the DMG from the JetBrains site and copy the application over


Well, crap.  Now I'm having a variation of the issue and none of the solutions above fix it.  I'm now on High Sierra, and I get the error only when attempting to use the command line tool for WebStorm:

I've tried the `xattr` & `chmod` solutions referenced, as well as deleting, reinstalling from .dmg, and recreating the command line launcher in a myriad of ways & nothing seems to solve the problem.

Help, anyone?


@Yaroslov, that was indeed the fix.  Thanks!


This happens to me on a brand new Mac


and my machine


Same problem here. 

macOS Mojave 10.14.1

IDEA does not have write access to /Applications/IntelliJ IDEA.app/Contents. Please run it by a privileged user to update.


And if I start IntelliJ with sudo, I have to accept the AGBs again, fill in the license information etc? I aborted at this point because I didn't want to risk a fresh installation and losing all my stuff...


Please make sure permissions for /Applications/IntelliJ IDEA.app/Contents directory are correct and the user can write there.


Please sign in to leave a comment.