Unable to Create Node.js Express App - Linux Ubuntu

When trying to create a Node.js Express app, the Version, Template and CSS options are "Unavailable". The Node Interpreter is "/usr/bin/node" v4.2.6.

If i try click the create button, an error pops up saying "Please specify npm package". 

Im new to node, so is there something that I am no doing right? What info do you need from me? I have tried creating an app with IntelliJ and with WebStorm and both have the same problem.

Thanks for any help.


Please can you provide your idea.log (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files)?

Also, what is the result of running `which npm` command in terminal?


I need the same help, but with Webstorm. I am running Ubuntu 18.04 LTS,
which npm results in /usr/bin/npm

Any advice for me?


I can see the following error in your log:

Failed to run 'npm config get prefix'
com.intellij.execution.ExecutionException: Please specify npm or yarn package

did you try specfying path to npm explicitly?



Hi Elena,

Yes I was specifying the npm package but I was using an older version of nodejs (8.1.0 I think). Once I updated my nodejs everything worked automatically. After struggling all day yesterday.

Thanks though. :)



Jetbrains has gone downhill big time. Seems like they have too many products to provide support for. I'm a paying customer for a few years now and I find it frustrating to use their products across platforms. When it takes 3 hours to figure out why npm can't be found (or npm-cli.js, or Express can't create a new project based on npm) you have to wonder how much testing goes into their features.

Now I also get that there's a difference between WebStorm and WebStorm plugins which aren't necessarily developed by Jetbrains. But then again that's why I moved away from Netbeans and Eclipse in the first place! But in this case I believe the Node integration plugin is provided from Jetbrains.

Seriously Jetbrains - you need to get your ship squared away. You need to provide a plugin repository that has quality plugins and if this is not an issue with plugins or the plugin is developed by Jetbrains then shame on you.

I'm still working on this stupid issue. Everything looks fine and I have tried both apt-provided node/npm and nvm-provided node/npm. Both times problems.


>Everything looks fine and I have tried both apt-provided node/npm and nvm-provided node/npm. Both times problems.

Do you have problems creating Express app? Did you try specifying a path to your npm package in File | Settings for new projects (Default settings in previous versions) | Languages & Frameworks | Node.js and NPM, Package manager:? Note: it should be a path to package, not to npm executable. Like `/usr/local/lib/node_modules/npm`

If it doesn't work for you, please attach a screenshot of this settings page and your idea.log


Please sign in to leave a comment.