Play2 Framework: Scala Tests Don't Compile in Play2

I have a Play 2 project and have imported the project via Import...SBT. In order to enable compiling within Intellj I have checked the Play2 config: "Use Play 2 compiler for this project". The problem is that when I compile the project from Intellij I can't figure out where the output directory is for the classes and consequently can't run tests because I get a ClassNotFoundException. After compile, there are no classes or test classes compiled to the target/classes or target/test-classes directories.

I have tried to change the compiler from Intellj to SBT but that didn't help. If I run the build from SBT it works just fine and compiles the classes to the target directory. I have double checked the output directories that are defined in the module configuration settings and they are pointing to the target directory.

I see random questions around and including on this forum with no answer but I'm assuming I must be missing some configuration setting because this issue has been around for a very long time.

Any help would be greatly appreciated!

Please sign in to leave a comment.