<<<EOF ... EOF; wrong code indentation

As you can see in image below, i can't find a way to add correct indentation style on phpstorm settings page.

Is there any way to do this? 

I would ask too if you can threat the slice of code inside <<<EOF '' EOF; tags as simple html, now it's not completing automatically.

 

2 comments
Avatar
Vladimir Luchansky
Comment actions Permalink

Hello,

Place the caret inside the EOF tags where HTML code is, press Alt+Enter and select "Inject language or reference", then select HTML from the list.

0
Comment actions Permalink

Well, for HTML you can use <<<HTML instead of <<<OEF (same works with CSS,SQL,JS,REGEX -- those are default/predefined labels as per Language Injections settings (you can check them in Settings/Preferences))

 

0

Please sign in to leave a comment.