Only 1 out of 6 Blaze Meteor app examples provided in WebStorm 2016.2 actually starts :(


Among the tutorial Blaze Meteor apps provided in the template menu of the create Meteor app dialog, only the ultra-trivial default template containng the hello project executes.

For the clock, leaderboard. localmarket and simple-todos example upon lauching a debug session WebStorm appears to enter in a loop, not starting the proxy, the MongoDB or the app itself.

For the todos example, Webstorm does start the proxy and MongoDB but then seems stuck before lauching the app itself.

Is this a know problem?

If it is, why keeping these projects in the menu of the most recent version of WebStorm or Meteor is not backward compatible with the example tutorial code they contain?



Comment actions Permalink

Issue might be related to
I've heard lots of complaints about problems running meteor for the very first time. Restart usually helps

Comment actions Permalink

The issue you point out to only happens when trying to run the same Meteor app at least twice on different ports each time.

It thus seems unrelated to mine since all the runs I tried where using the same default port http://localhost:3000.

What do you mean by Restart?

Click on the debugger's button which tooltip says: Rerun "Run Meteor"

or first click on the button which tooltip says: Stop "Run Meteor", and only then click on the button which tooltip says: Rerun "Run Meteor".

or Restart WebStorm?

I tried all of them and the issue persists.


Comment actions Permalink

>The issue you point out to only happens when trying to run the same Meteor app at least twice on different ports each time.


no - just some of the comments in the issue refer to changing the port


>What do you mean by Restart?


restarting meteor; you can also try starting it in terminal and, once it completes successfully, start it in WebStorm

Comment actions Permalink
Wednesday at 18:03

Issue might be related to


Well in that issue the problem is Meteor getting stuck after the "Starting your app" stage.

In Meteor app examples included in Webstorm that I ran (clock, leaderboard, localmarket and simple-todos), the app does not even get to neither the proxy, nor mongo, so of course the app doesn't even starts. 

Now I tried to typed "meteor reset" in the terminal (since I assumed this what you meant by "restarting meteor" for I could not find a "meteor restart" command in the meteor command line doc) for each of these apps, and it triggered a download of the older meteor version in which the app was written. 

C:\Users\Jacques\WebstormProjects\leaderboardSpacebarCssJs>meteor reset
Downloading meteor-tool@1.3.4_4... [=== ] 13% 37.0s

After the download completed, the extraction started:
C:\Users\Jacques\WebstormProjects\leaderboardSpacebarCssJs>meteor reset
Extracting meteor-tool@1.3.4_4... -

at this point, for the odd numbered attempts: the extraction enters an seemingly infinite loop,

for the even numbered attempts: the extraction throws an unexpected eof exception:
throw error;

Error: unexpected eof

The only Meteor app example provided inside Webstorm that actually executes properly is the hello example because it is the only one implemented using the latest Meteor version.

So in fact it is the correction that you seem to proposed (typing meteor reset) that triggers the meteor bug mentioned in, but the root cause of the problem seems to be that Meteor (or is it Webstorm?) implements backward compatibility by checking the project's Meteor version before running the app code and if the latter does not match that of the Meteor installed on the computer, it downloads the correct (legacy in our cases) version from the Internet, unzip it, replace the non-matching one in the project folder with the matching one and then starts running this project-specific version (legacy in our case)?

Do you think this is how it works? It seems a rather bizarre overkill approach to me, but then again I am not app framework developer. 

Thank you very much for your help.


Comment actions Permalink

Similar errors are reported by many users, and it's not specific to `meteor reset` - it may occur on running application, on updating it, etc. See for the list of possible workarounds.

I can tell for sure that WebStorm doesn't do anything special here - it just calls meteor cli, passing commands to it. Sample projects are also Meteor own ones, and they are created using Meteor. The release downloading in background is meteor own feature, not something invented by JetBrains:)


Please sign in to leave a comment.