InteliJ 2016 Create Pull Request

Answered

Hi,

I don't see the create pull request in my IJ, though in the IJ help it seems the dialog should be available.

Are the help documentation not updated or am I missing something?

 

thanks,

Ran.

9 comments
Comment actions Permalink

Create Pull request option is available when remote of a project points to GitHub

If it is so, option to create Pull request, as well as couple others, should be present. Creating Pull request is done in VCS - Git - Create Pull Request...

In general you need to make sure a remote points to the server specified in Settings - Version control - Github. github.com is just a default, it might be other server, e.g. Github Enterprise

 

1
Comment actions Permalink

Hi,

thanks for the reply.

I am using a TFS git - is there a way to enable a pull request, maybe another plugin?

 

0
Comment actions Permalink

Yes, for TFS integration it is a different story.

That plugin should work, however please note it supports TFS 2015 only.  

0
Comment actions Permalink

Hi, this is a helpful info as I couldn't guess why the Create Pull Request action was disabled in my IDEA.

Now I know why, I'm still keen to find out what would be an appropriate workaround for it in my case. Client asked me to use a separate GitHub account for access to their organization's repos. So I have two SSH identity files and a relevant SSH config with github.com host alias for use with client's repos. It goes like this:

$ cat ~/.ssh/config 
Host github.foo
        HostName github.com
        User git
        IdentityFile ~/.ssh/rsa-me-at-foo-identity

Quite common approach if multiple SSH identities are in use.

Then there is a relevant git remote config for a client repo:

$ git remote -v
origin  git@github.foo:foo-organisation/foo-repo.git (fetch)
origin  git@github.foo:foo-organisation/foo-repo.git (push)

Obviously IDEA can't recognize 'github.com' among repo's remotes so the Create Pull Request remains disabled.
I've tried to change repo's remote host to github.com and then it's enabled so I'm sure that's the case.
Obviously it doesn't work anyway as my default identity has no access to this repo.

Any idea (or perhaps I should ask, any IDEA) how to tackle this issue?

0
Comment actions Permalink

Temporary change the hostname to github.foo (see my last screenshot)

0
Comment actions Permalink

Thanks for the quick reply.

This requires an additional setup, some kind of a host alias or proxy, but not SSH as pull request goes through GitHub REST API over HTTPS.

I've done such, for now just to try, by adding /etc/host entry as follows:

$ cat /etc/hosts | grep github
192.30.253.112    github.foo

This is not ideal as it ties to a specific GitHub IP but I could live with it.

However, SSL certificate doesn't match the domain name obviously, which prevents IDEA to connect.

17:42    Can't Create Pull Request: Host name 'github.foo' does not match the certificate subject provided by the peer (CN=github.com, O="GitHub, Inc.", L=San Francisco, ST=California, C=US, OID.2.5.4.17=94107, STREET="88 Colin P Kelly, Jr Street", SERIALNUMBER=5157550, OID.1.3.6.1.4.1.311.60.2.1.2=Delaware, OID.1.3.6.1.4.1.311.60.2.1.3=US, OID.2.5.4.15=Private Organization)

 

0
Comment actions Permalink

Seems you need support for several GitHub accounts - vote for https://youtrack.jetbrains.com/issue/IDEA-82222

0

Please sign in to leave a comment.