The C compiler "C:/MinGW/bin/gcc.exe" is not able to compile a simple test program. please help

hello guys I have tried everything to solve the problem. by google I could find nothing pls help me. i tried to install cygwin but it will not working on my system.


Error:Configuration RelWithDebInfo
The C compiler "C:/MinGW/bin/gcc.exe" is not able to compile a simple test program.
It fails with the following output:
 Change Dir: C:/Users/Fatih Gökalp/.CLion2016.2/system/cmake/generated/untitled2-436f507b/436f507b/RelWithDebInfo/CMakeFiles/CMakeTmp
Run Build Command:"C:/MinGW/bin/mingw32-make.exe" "cmTC_3139e/fast"
C:/MinGW/bin/mingw32-make.exe -f CMakeFiles\cmTC_3139e.dir\build.make CMakeFiles/cmTC_3139e.dir/build
mingw32-make.exe[1]: Entering directory 'C:/Users/Fatih Gökalp/.CLion2016.2/system/cmake/generated/untitled2-436f507b/436f507b/RelWithDebInfo/CMakeFiles/CMakeTmp'
Building C object CMakeFiles/cmTC_3139e.dir/testCCompiler.c.obj
C:\MinGW\bin\gcc.exe -o CMakeFiles\cmTC_3139e.dir\testCCompiler.c.obj -c "C:\Users\Fatih Gökalp\.CLion2016.2\system\cmake\generated\untitled2-436f507b\436f507b\RelWithDebInfo\CMakeFiles\CMakeTmp\testCCompiler.c"
gcc.exe: error: C:\Users\Fatih G+Âkalp\.CLion2016.2\system\cmake\generated\untitled2-436f507b\436f507b\RelWithDebInfo\CMakeFiles\CMakeTmp\testCCompiler.c: No such file or directory
gcc.exe: fatal error: no input files
compilation terminated.
CMakeFiles\cmTC_3139e.dir\build.make:64: recipe for target 'CMakeFiles/cmTC_3139e.dir/testCCompiler.c.obj' failed
mingw32-make.exe[1]: *** [CMakeFiles/cmTC_3139e.dir/testCCompiler.c.obj] Error 1
mingw32-make.exe[1]: Leaving directory 'C:/Users/Fatih Gökalp/.CLion2016.2/system/cmake/generated/untitled2-436f507b/436f507b/RelWithDebInfo/CMakeFiles/CMakeTmp'
Makefile:125: recipe for target 'cmTC_3139e/fast' failed
mingw32-make.exe: *** [cmTC_3139e/fast] Error 2
CMake will not be able to correctly generate this project.




1 comment
Comment actions Permalink

Hi Fatih.

We suppose that it's not CLion problem, but problem with using CMake + MinGW, because they don't support non-latin symbols.

To solve the problem you can

1) change usage of MinGW to Cygwin or

2) сhange idea.system.path in the IDE_HOME\bin\idea.properties file so it won't contain non-latin symbols (please see https://intellij-support.jetbrains.com/entries/23358108 and https://www.jetbrains.com/idea/help/project-and-ide-settings.html for more details).

Also we have an article in our web help about configuring CLion on Windows: https://www.jetbrains.com/help/clion/2016.1/quick-tutorial-on-configuring-clion-on-windows.html.

0

Please sign in to leave a comment.