PySide .pyd file not recognized in PyCharm


I'm connecting to a python installation included in a DCC package (3dsMax) and when adding the python interpreter, it builds a skeleton except for everything PySide related. Even though the .pyd modules exist in the referenced python installations's site-packages\PySide.

I've done this before at work and every time it's a nightmare. Currently my only resort is to manually install PySide on a separate python installation and use that as my interpreter rather than the one included.

I run in Admin mode, I've tried Invalidating Caches...

If I simply try to from PySide import QtCore from the Python Console I get:

Traceback (most recent call last):
File "<input>", line 1, in <module>
File "C:\Program Files (x86)\JetBrains\PyCharm 2016.2.3\helpers\pydev\_pydev_bundle\", line 21, in do_import
module = self._system_import(name, *args, **kwargs)
ImportError: DLL load failed: The specified module could not be found.

I'm really at a loss. If anyone has any insight.

This was working on 2015... I'm hitting a wall now.



In case anyone else runs into this problem, I solved it by installing 

Microsoft Visual C++ 2010 Redistributable Package (x64)


When I posted this message, I was reinstalling software on a brand new computer so this might have been most likely the cause. Following all of my software installations, it seems the problem disappeared.


Please sign in to leave a comment.