Pycharm - Auto Completion in getters and setters

Answered

Good afternoon,

I am not sure if this is an error or some "feature" that I am no understanding regarding the auto code generation for the class getters/setters.

Bear with me if you will for a moment, please.

The issue I am getting revolves around creating class getters/setters using the "props" (and prop) for that matter. When I use them, the code is generated (really awesome by the way, love that), I fill in the name of the getter/setter and then go to insert a docstring using '''.

What happens is as follows.

If I have a method generated like this:

@property
def name(self):
'''''' (now here I move the cursor to the middle, and press enter to generate the docstring.
@property
def name(self):
'''
:return:
:rtype:
'''''' <<----- it adds another triple apostrophe

This happens when inserting the docstring, using any of the prop/s/sd utilities, sorry not sure what the official
description is for these keywords that come up as you type.

It isn't a devestating error, just slightly annoying to have all the rest of the code after the getter line commented out. :)

Just thought someone might like to know about it. If it is a design feature for something I am not aware of, well,
it works perfectly then.

Thanks for a great product, and thank you very much for a community (free) version for those of us hobbyists that can't
afford huge software budgets.

Bob

3 comments
Comment actions Permalink

Hi Bob,

Welcome to the PyCharm community board!

Could you please let me know which version of PyCharm you're using? I can't reproduce your issue in the most recent public preview version of PyCharm.

The feature you're using to generate the code is called 'Live templates', and you can edit them in the PyCharm settings (File>Settings, or Ctrl+Alt+S). You can also define your own custom live templates if you need any new ones for your project.

Thanks for using PyCharm!

Ernst

0
Comment actions Permalink

Good afternoon Ernst!

ok, as I remember, I just upgraded to community edition 2016.2.3 within the last several days. I am unable to replicate the error now myself, so well done! nice repair!

 

If I see it again, I will repost with more details.

thanks

Bob

0
Comment actions Permalink

That's good to hear!

If you find a bug (this one or anything else), you can always report it on our bug tracker (https://youtrack.jetbrains.com/issues/PY) as well.

Have a great day!

Ernst

0

Please sign in to leave a comment.