Multiple projects inside one window -> "idea uses a non-standard layout and cannot be attached to this project"

Answered

Every time I try fetch from github and open in the same window it says "The project at .../.idea uses a non-standard layout and cannot be attached to this project"
I'm testing PyCharm 2016.3 EAP , how it can be fixed?

9 comments

Same problem here in PHPStorm. This was the only thread i found regarding this topic.

 

0

@Madzohan Please, file this issue with your idea.log (Help| Show log) to Pycharm issue-tracker: https://youtrack.jetbrains.com/issues/PY.


@David, it's a known issue about PhpStorm, please vote for the issue: https://youtrack.jetbrains.com/issue/WI-33637 to be notified about updates.


0

Hi there,

I experienced the same issue. I upgraded to Pycharm CE 2016.3 yesterday. Projects created in older version were opened correctly in one window, but new project needs to be opened only in new window:

As you suggested, I searched for idea.log. The problem is that there is no new log message/error, anything in it. Not even in the threadDumps, nowwhere - I tried it multiple times. So I see no point in sending you log files.

Though! I might have workaround: just simply close all PyCharm windows and reopen PyCharm. Even the new project is then placed in one window together with others. This worked for me...

3

I can confirm what @Petr mentions is correct.  When I got the dialog mentioned the project uses a non-standard layout, I clicked on No.  I then closed PyCharm and reopened it and the second project was added to the main project and everything seems normal.

1

I have this problem in PyCharm Professional 2016.3. I can't add a fresh Git checkout to an existing project. I can open it in a new window, and the .idea/ directory gets created. Adding to the existing project doesn't work after that either.

I've tried closing and re-opening PyCharm, and it doesn't make a difference.

I did accidentally open my existing project in PyCharm 2016.2.3 one time. I then closed it and opened it in PyCharm 2016.3 instead, after which this problem appeared.

I also observed that some Git checkouts get added to the project even though I get the "non-standard layout" error message and click "No", while others don't get added. I don't see anything related in idea.log in either case – just PerformanceWatcher ok messages and GitConfig "No branch.*" complaints from other projects.

I guess I'll try recreating the existing project from scratch.

0

Confirm; I have the same problem. It persists even when adding one completely fresh project to another fresh project. 

 

 

0

The above solution by Petr worked for me! 

 

Still would be good to fix it. 

0

i had the same problem for two times, at different folders. sometimes, re-cloning directory from git can solve this; but you can solve it manualy. That problem is caused by the lack of projectName.iml folder (your project name at place of projectName) in ".idea". you can just create a new project, and copy its new_projectName.iml file (your new project name at place of new_projectName) and change its name to projectName.iml (your project name at place of projectName). Then, it will work.

6

Njt145's comment fixed this for me. Turns out the project that wouldn't load was missing the project iml file in the .idea folder.

2

Please sign in to leave a comment.