Can't disable autosave

I have unchecked "Synchronize files on frame or editor tab activation" and "Save files on frame deactivation" settings but webstorm auto saves my files as soon I make some changes. I don't use any file watchers. Is there a way to disable auto save?

I'm using WebStorm 2016.2.4

12 comments
Comment actions Permalink

Mentioned settings just disable files saving on losing focus. Auto-save is a core IDE feature that can't be disabled completely. Auto-save can happen at multiple stages: e.g. making changes in Settings, running command in Terminal, executing/debugging scripts etc.

But normally saving doesn't occur immediately on each change. Does the problem affect all files, or some certain ones only? Do you have debug session active?

0
Comment actions Permalink

Yes, I do have an active debug session as I'm working on express app. Disabling debug session disabled the auto save as well, thanks for pointing that out. Is there a way to keep debugger active but disable autosave?

0
Comment actions Permalink

Yes - try disabling Live Edit plugin. Related ticket: https://youtrack.jetbrains.com/issue/WEB-7093

0
Comment actions Permalink

Disabling the Live Edit plugin fixed the problem. Thanks!

0
Comment actions Permalink

I'm currently using Webstorm 2017.2.4 and regardless of what configuration I have in Settings -> Synchronization, Webstorm saves every keystroke. Live Edit plugin disabled, no file watchers, no debugging, nothing.

I have several watchers running in my terminal and they keep firing every single key stroke because of Webstorm, slowing down my machine.

The only way I can disable this is by enabling the power save mode, which also disables all inspections and I don't want that. There is literally nothing special in my environment, all I'd like is that the configurations I set in Settings -> Synchronization work as I set them. Regardless of the power save mode flag.

0
Comment actions Permalink

Please, check this answer: http://stackoverflow.com/a/7377886.

Also feel free to vote and comment this request: https://youtrack.jetbrains.com/issue/IDEABKL-6460.

0
Comment actions Permalink

Do you have any custom plugins installed? They can also be responsible for auto-saving -,for example, Flow service, when enabled, flashes files to disk to submit up-to-date files to Flow type checker, third-party SonarLint and ESLint plugins are known for causing such issues, as they save files to run analysis on the changes, etc.

0
Comment actions Permalink

 

Here I am in late 2017 and this is still an issue. Disabling LiveEdit plugin completely was the only thing that stopped my LESS/CSS files being written to disk on every keystroke. I have no file watchers in Webstorm (only Grunt running externally) and all auto-save and auto-syncronize features were already turned off.

Looking at https://youtrack.jetbrains.com/issue/WEB-7093 this has been an issue since at least 2013. 

1
Comment actions Permalink

This is unacceptable! Why is this still an issue? I just started using IntelliJ recently. This is a showstopper.

1
Comment actions Permalink

What issue? Auto-saving by Live Edit is not a bug, Live Edit has to auto-save files in order to provide live reload. But this only happens during JavaScript Debug session, and is not an issue if Live Edit is disabled

1
Comment actions Permalink

My comment is in general with auto-save and its use in JetBrain products (IntelliJ / PyCharm). You can disable some auto-save "features" such as "saving after n minutes" or "save files on frame deactivation". For me, the showstopper is auto-save when exiting the program. No place to disable this. I could care less on someones use case for this feature; however, it is not a feature I find useful. In fact, it can be outright dangerous. There is no place to disable this. This was a very short honeymoon. After 4 hours of frustration, it's back to Eclipse. 

2
Comment actions Permalink

My issue is that I am debugging my Typescript React app in Chrome, and React/TS would recompile every time I typed, which resulted in a lot of React/Chrome hot-reloading and slowing Webstorm down.

I found the magic button, though! Preferences > Build, Execution, Deployment > Live Edit. Uncheck "Update application in Chrome" and Chrome won't get updated/reloaded by Webstorm. Your React server will still perform your hot-reaload only when you actually hit save.

If you're watching in several terminals and that's slowing you down then this won't help, but this made a huge difference for me.

0

Please sign in to leave a comment.