IDE Error: "Could not create folder"

Answered

Since the last update to 2016.3.1 EAP I receive following errors every time I save my files:

09:39 PHP Mess Detector
Failed to create file '/home/vagrant/.phpstorm_helpers/phpmd_temp.tmp/src/Acme/Acme/BaseUserBundle/Service/ProfilePicManager.php': could not create folder "sftp://172.16.81.150/home/vagrant/.phpstorm_helpers/phpmd_temp.tmp/src/Acme/Acme/BaseUserBundle". (No such file),
Disable inspection

09:39 PHP Code Sniffer
Failed to create file '/home/vagrant/.phpstorm_helpers/phpcs_temp.tmp/src/Acme/Acme/BaseUserBundle/Service/ProfilePicManager.php': could not create folder "sftp://172.16.81.150/home/vagrant/.phpstorm_helpers/phpcs_temp.tmp/src/Acme/Acme/BaseUserBundle". (No such file),
Disable inspection

 

PHP Mess Detector and PHP Code Sniffer were working fine before. They are located inside my vagrant.

 

*EDIT*: I've reverted to version 2016.3 and there the issue does not exist.

18 comments
Comment actions Permalink

Hello,

I cannot reproduce this with 2016.3.1 EAP that was released yesterday.

My remote PHP interpreter is configured via Vagrant integration (not a Deployment configuration or SSH credentials) and PHPCS and PHPMD are using this interpreter with remote paths to executables.

Did you report that exception as button suggests?

0
Comment actions Permalink

Yes I did! Yeah I don't know why it started happening in 2016.3.1 EAP. Mine is also configured via Vagrant integration, in 2016.3 it works fine.

0
Comment actions Permalink

Got the same error: Failed to create file '/root/.phpstorm_helpers/phpcs_temp.tmp/src/AppBundle/Controller/AdminBankPayoutController.php': could not create folder "sftp://[my server ip]:2022/root/.phpstorm_helpers". (Permission denied), 

Updated to: PhpStorm 2018.1.1

Got error when running Code Sniffer with remote interpretter.

User for ssh connection is not "root". 

0
Comment actions Permalink

Working with Dmitry in a support ticket, will share the results here.

0
Comment actions Permalink

Any news in here? The same error on 2017.3.4

0
Comment actions Permalink

Hi Mtrybula, I got such progress in support after checking my "env":

Eugene Morozov:

Hi Dmitry,

Everything looks legit!
It seems that the interpreter has wrong data caches.
Please re-create the PHP interpreter using the same deployment configuration and try to configure PHPCS for it, would that help?

Dmitry Diavita

Hi Eugene, thanks a lot, it is helps

1
Comment actions Permalink

Thanks Guys. Works for me too.

0
Comment actions Permalink

yo guys
im having the exact same error and im pretty new.

how should i "re-create the PHP interpreter" as Dmitry said above?

 

0
Comment actions Permalink

Hi,

When I installed PhpStorm 2019.2(now 2019.2.2) I have the same bug. Php Code sniffer is dead...

Failed to create file '/home/vagrant/.phpstorm_helpers/phpcs_temp.tmp/...: could not create folder "sftp://127.0.0.1:2222/home/vagrant/.phpstorm_helpers/phpcs_temp.tmp/...". (No such file),

I use php interpreter by Vagrant and I never had a problem with it. After update the all time I have this above bug. Of course I tested via ssh, but doesn't work...

 

Here is ok, but I show errors(interpreter by vagrant):

 

Any idea?

0
Comment actions Permalink

I guess the problem is with the version.
After downgrading to 2018 version the problem is solved.

0
Comment actions Permalink

I use php interpreter by Vagrant and I never had a problem with it. After update the all time I have this above bug. Of course I tested via ssh, but doesn't work...

It appears to be an issue with the new SSH library we use in 2019.2.

Please add #com.intellij.ssh and #com.jetbrains.plugins.webDeployment to Help | Debug Log Settings, restart PhpStorm, reproduce the issue and then submit the logs bundle (Help | Compress Logs) within a bug report: https://youtrack.jetbrains.com/newIssue?project=WI

Thank you!

0
Comment actions Permalink

Someone went ahead and created the issue, many thanks to this person: https://youtrack.jetbrains.com/issue/WI-48678

1
Comment actions Permalink

Reported @issue WI-48678

0
Comment actions Permalink

I have the same problem and created the task: https://youtrack.jetbrains.com/issue/WI-48561

-1
Comment actions Permalink

@Wiktor Pikosz Why would you create a duplicate issue ???

Never mind, it has already been deleted :)

0
Comment actions Permalink

I created my task 2 weeks ago... But nobody added comment/answer/... So probably you task is duplicated :) 

0
Comment actions Permalink

Looks like your issue does not exist (any more) ...

0

Please sign in to leave a comment.