2016.3 is a nice release. But the cpu is still on 100%

Answered

First of all: 2016.3 makes my want to use AppCode more again. Great move :-)

But I really wonder why the 100% cpu hog problem is still there... Me and other have repeatedly reported this problem, but I do not see a clear strategy how avoid this. Thankfully the Toolbox app helps making some settings on the Java stuff easier.

But still I have to mess around with the VM options again and again (the below ones currently work). Cant AppCode or the Toolbox just set this stuff as required? Settings seem to be forgotten from time to time. 

 

-Xss2m

-Xms256m

-Xmx1200m

-XX:NewSize=128m

-XX:MaxNewSize=128m

-XX:MaxPermSize=350m

-XX:ReservedCodeCacheSize=96m

-XX:+UseCompressedOops

-agentlib:yjpagent=delay=10000

2 comments
Official comment

Raymund, thanks for the feedback.

Have you reported the problem in the tracker with a CPU snapshot

This was driving me up the wall (2+cores sometimes). I downloaded and am running 2017.1 EAP since this morning, and have not had to throw my puter in the ice box once.  

Good job Jetbrains ... hope it holds, but so far so good.

0

Please sign in to leave a comment.