[2016.3] Juypter notebook hangs on cell "run"; post error

Completed

Hi all,

I have a very strange issue since I upgraded from (macOS) 2016.2 to 2016.3. I followed this guide (create python 3.5.2 virtual env, create notebook, etc.).  I try to run a very simple print("hello world") in a cell and execute the cell and I get: 

[I 11:20:58.924 NotebookApp] Serving notebooks from local directory: [redacted]
[I 11:20:58.924 NotebookApp] 0 active kernels
[I 11:20:58.925 NotebookApp] The Jupyter Notebook is running at: http://127.0.0.1:8888/?token=a0f62fb8627d55b11f31e6bccceda380259977a81471d418
[I 11:20:58.925 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).
[W 11:20:58.963 NotebookApp] None
[W 11:20:58.964 NotebookApp] 403 POST /api/kernels (127.0.0.1) 1.77ms referer=None

I try executing the cell again and I get the same post error:

[W 11:23:07.717 NotebookApp] None
[W 11:23:07.717 NotebookApp] 403 POST /api/kernels (127.0.0.1) 0.95ms referer=None

If I connect to the jupyter server directly via browser I have no problem executing the notebook.

Any Ideas?

Thanks 

0
2 comments

Hi OP, having the same error with 2016.3 PyCharm Python 3.5.2 on OSX

Also tested with older versions of PyCharm and Python 2.7 on Windows, same error.

OP did you solve the error? thank you.

1

+Kevinfan

No, issue persists; downgraded for time being.

Submitted bug report here on YouTrack.

If you could bump the report that would be great.

0

Please sign in to leave a comment.