["solved"] Problem running/debugging project on a device

Hey folks,

I just started evaluating AppCode in hopes that it might help mitigate some of the constant pain I'm experiencing working with XCode and so far, I love it a lot.

One problem I'm running into though is that I can't run/debug/clean my project on a device. Running it in the simulators works fine but when I try starting it on my phone, I get:


Error:xcodebuild: error: Unable to find a destination matching the provided destination specifier:
Error:{ id:59b66d08127df0a4e4a17f1eb9fe6d5b740b7a6d }
Error:Unsupported device specifier option.
Error:The device “My Mac” does not support the following options: id
Error:Please supply only supported device specifier options.
Error:Available destinations for the "MySecretProjectName" scheme:
Error:{ platform:iOS, id:59b66d08127df0a4e4a17f1eb9fe6d5b740b7a6d, name:NameOfMyPhone }
Error:{ platform:iOS Simulator, id:DAEAC7FE-401A-46B8-B19C-201DF6188BB4, OS:9.2, name:iPad 2 }
Error:{ platform:iOS Simulator, id:209DBAEF-20D5-4758-8E9B-49CD2AE0963C, OS:9.2, name:iPad Air }
Error:{ platform:iOS Simulator, id:076ECDDA-5934-4ACC-839C-FC3ADC4F7D3E, OS:9.2, name:iPad Air 2 }
Error:{ platform:iOS Simulator, id:D26DF584-0699-4926-9F0C-2867E377BCD4, OS:9.2, name:iPad Pro }
Error:{ platform:iOS Simulator, id:4EA2D570-9F04-440C-9A15-C54B5A57F46B, OS:9.2, name:iPad Retina }
Error:{ platform:iOS Simulator, id:C00B7612-1C6A-4E45-A931-041D5D9DF733, OS:9.2, name:iPhone 4s }
Error:{ platform:iOS Simulator, id:018B9CE7-7E45-4C44-ADF0-752A14CFB85D, OS:9.2, name:iPhone 5 }
Error:{ platform:iOS Simulator, id:51A45C46-90C3-4C97-B87B-E3D88B925681, OS:9.2, name:iPhone 5s }
Error:{ platform:iOS Simulator, id:6FCD1FB7-F150-4656-9B59-7EC204177C58, OS:9.2, name:iPhone 6 }
Error:{ platform:iOS Simulator, id:8F45051E-8517-4E35-A4AC-ED0AFCCFC531, OS:9.2, name:iPhone 6 Plus }
Error:{ platform:iOS Simulator, id:8AC1D9FF-9EAD-4D40-BDFD-EF0840C042CC, OS:9.2, name:iPhone 6s }
Error:{ platform:iOS Simulator, id:B3220481-8F22-43F9-B2A7-52C140771753, OS:9.2, name:iPhone 6s Plus }
Error:Clean failed with 19 errors and 0 warnings in 31s 774ms



I tried googling for it but found nothing. I have the latest AppCode release installed (3.3.1) and Xcode 7.2, my phone is running iOS 9.2.

Any hints on how to solve this would be greatly appreciated.

EDIT: The problem was that after upgrading my phone to iOS 9.2, it needed the "Processing Symbols" step that automatically happens when trying to run the project through Xcode. Once that was done, I could also launch it using AppCode. Would be nice if the error message communicated more cleaner. Even nice if Appcode just did this same as Xcode does.

4 comments
Comment actions Permalink

Could you explain how you fix/triggered the "Processing Symbols" step? I'm experiencing the same issue.

0
Comment actions Permalink

Marcella,

Open project in Xcode, select the device as run destination and wait until "Processing symbols" is finished (progress can be monitored in Xcode's toolbar).

0
Comment actions Permalink

We have corresponding issue in our tracker - OC-12665. Please follow its progress and leave comments as you see fit.

0

Please sign in to leave a comment.