again (3.2) and again (3.1.x) and again (2.x) : 100% cpu while idling with no project open

Beachballs in a tiny project are no fun, but 100% cpu with no project open is insulting. When are you going to solve this problem instead of playing 'Youtrack' ?  


Screen Shot 2015-10-02 at 10.30.46 AM.png

4 comments
Comment actions Permalink

Yves,

That is a platform issue IDEA-126337 which we are not able to reproduce in builds from 142.x branch (AppCode 3.3 EAP).
We believe it was fixed but to make sure could you please try 3.3 EAP out and get back to us if you happen to see the issue there?

0
Comment actions Permalink

yeah ... maybe. But since the appearance/disappearance of the problem seems totally random (I have never been to create a 'sure fire' way of causing it, nor getting rid of it) ... our mileage will vary on this. The real question is whether Mr. Platform-142 has tried anything to fix the specific issue , or whether we are all praying for a fix.

I am not installing an EAP nor any version that will require me to install Xcode 7.x until i am ready for yet another forklift, so dont hold your breath.

0
Comment actions Permalink

YvesLeBorg wrote:

The real question is whether Mr. Platform-142 has tried anything to fix the specific issue , or whether we are all praying for a fix.

There were also various changes in third-party code (Netty) which are influencing, that's why we cannot tell for sure that our changes in 142.x branch have fixed the problem.

0
Comment actions Permalink

I guess Maven or Gradle or whatever you are using, 'hoping' that dependency refreshes would magically cure the issues. I was hoping for something like 'I fixed this' , or 'I tested that'. Netty has been mentioned since the very begining of this issue, so i am not hoping for much here. I'll let you know when i get there.

0

Please sign in to leave a comment.