unresolved references for builtin modules

Completed

hi,

i'm using maia 94.426 and python plugin 2.5.2 on os x 10.6.2.  I have been unable to have IDEA recognize the python builtins.  My own modules within the same directory are recognized.  If I debug and step into a builtin module, it shows me the source code for that module.

I look at the classpath and sourcepath for the python SDK and they look valid.  I've removed, and re-added python in SDK dialog.  I've also invalidated the cache, disabled all plugins except python but still no change.

is there something else I'm missing?

thanks

lex

3 comments

I do not know what caused it, but after recreating the project has resolved my issue.

0

CLion 3.1 was not recognizing common Python modules on my Linux workstation.   I noticed that the Python Interpreter was not set (File->Default Settings...->Build, Execution, Deployment->Python Interpreter), so I set it.  At first that seemed to fix the problem.  However, later I noticed that the modules were no longer recognized in the same python script.  I tried restarting CLion, but no improvement.

I then closed CLion, blew away the .idea directory, and reopened the project.  Everything was great.  I could even Go To->Declaration on "os" and it would open os.py.  However, when I subsequently restarted CLion, it could no longer find them anymore.

There is definitely instability going on.

0

Please sign in to leave a comment.