FreeBSD

I see that linux is supported for PyCharm, but under the requirements there is none for the linux kernal version. Would it be possible to use PyCharm on FreeBSD? Are there any potential complications?

Thanks in advance!

2 comments
Comment actions Permalink

Hi John,

I see that linux is supported for PyCharm, but under the requirements there is none for the linux kernal version. Would it be possible to use PyCharm on FreeBSD? Are there any potential complications?

PyCharm requires Sun JDK6, but Oracle doesn't  provide it for Free BSD.

However there are some instructions on installing FreeBSD Java project on the internet http://www.freebsd.org/java/install.html

Please NOTE this is not officially supported.

Best regards,

Oleg

0
Comment actions Permalink

I got an early version of PyCharm running on a FreeBSD box. Can't remember what I did to get it working but I can confirm that it works!

0

Please sign in to leave a comment.