Simulator missing in AppCode 3

Hi,

I've recently upgraded to AppCode 3.0.1 and since then the pre-iOS-8.0 simulators are missing from the dropdown. From XCode 5.1 I still can use 6.1, 7.0 and 7.1 simulators so they're installed, but in AppCode I only see 8.0 versions. It's probably relevant to mention that the first time I ran AppCode 3 I didn't see any simulators. Based on some information I found somewhere on this forum (I forgot the exact post) I installed XCode6-beta and accepted the license agreement. From that point on the 8.0 simulators appeared. However the other ones are not there (and I kind of need them...)

Anyone any idea what may be the issue?

Have a great day! Olaf

2 comments
Comment actions Permalink

Hi Olaf,

AFAIK Xcode 6 includes the iOS 8 simulator, with 7.0 and 7.1 as optional downloads.
Xcode 6 does not automatically pick up on simulators installed with Xcode 5.
Did you download those simulator versions in Xcode?

If you need older simulators (like 6.1), make sure to select your Xcode 5 install as the one to be used by AppCode (in AppCode preferences).

Kind regards,
Maarten

0
Comment actions Permalink

Thanks a lot! I never realized AppCode is actually pointing to a specific XCode installation. It pointed to XCode6 (that didn't have pre 8.0 simulators either) and after switching and restarting the older simulators are back! So problem solved :)

Olaf

0

Please sign in to leave a comment.