"unexpected argument" errors after upgrade to IDEA 10.0.2 and plugin 2.6.6

After upgrading to IDEA 10.0.2 (103.72) and Python plugin 2.6.6, I'm getting alot of "unexpected argument" errors in the editor for Python standard library functions (such as time, cStringIO, socket, re, os), as well as some project library functions/methods.

"duplicate argument" is also showing up in a few places.

Also, simple decorators defined in the project are all showing "... lacks a positional argument" errors.

This happens with Python 2.5.4 and 2.6.6.

Are these known issues?

1 comment
Comment actions Permalink

I'm also seeing this in 10.0.3.  Pretty much makes python warnings useless as the entire right bar is yellow.

0

Please sign in to leave a comment.