How to configure working directory for google app engine deployment

Hi,

I had a project, and after working on it for a while I made it a google app eninge project.  I have been able to configure the run configuration so that I can run a development server just fine, but I get an error when I try to deploy.

/Library/Frameworks/Python.framework/Versions/2.5/bin/python /usr/local/google_appengine/appcfg.py -e bonelake@gmail.com --passin --no_cookies --severity=0 request_logs . -

Host: appengine.google.com

Usage: appcfg.py [options] request_logs <directory> <output_file>

appcfg.py: error: Directory does not contain an app.yaml configuration file.

I definitely have an app.yaml file, so it seems to me its simply a matter of convincing the Tools | Google App Engine | Upload App Engine App that it should look in my main project directory rather than using .
Brad
3 comments
Comment actions Permalink
Did you eventually solve this as I have just come across the same issue?
0
Comment actions Permalink
What is the structure of your project? PyCharm looks for the app.yaml file under the content roots of your project and uses the directory containing that file as the working directory when running appcfg.py.
0
Comment actions Permalink
I fixed this in the end via preferences and the working directory for both
Python and Django, although it seems that I also had to restart Pycharm for
this to work.

The app has now deployed to app engine using Pycharm without issue.

---
Kevin Tucker
Mob:+44 (0) 7970 520506
---
Twitter: @kevtuck | Skype: kevtuck
LinkedIn: linkedin.com/in/kevtuck
---
Google Adwords Certified Partner & Professional



On 8 November 2012 13:30, Dmitry Jemerov - PyCharm
0

Please sign in to leave a comment.