Imported two projects, can't edit configuration or project settings

I imported two existing projects that were mostly recently built with XCode 5.  However all I can do is Build them (And release only.)  Run/Debug/Profile/Edit Configurations etc... are greyed out of the Run menu, and Project Settings is greyed out of the File menu.  Command-; doesn't respond either.  The activity strip at the bottom is still Scanning files to index as it has been for the past 3 hours, and in Activity monitor it's using 113-178% of CPU across 70 threads.

Any idea what to do?

5 comments

As a followup, it's run out of memory 3 times so far, and I've upped Vmx up to 8192 in the latest try before doing that at 4096 I had to force quit with:

Date/Time:       2013-10-21 11:00:17 -0700
OS Version:      10.8.5 (Build 12F37)
Architecture:    x86_64
Report Version:  11

Command:         AppCode
Path:            /Applications/AppCode.app/Contents/MacOS/appcode
Version:         2.5 (OC-131.302)
Parent:          launchd [236]

PID:             25778
Event:           hang
Duration:        3.99s
Steps:           40 (100ms sampling interval)

Hardware model:  MacBookPro8,2
Active cpus:     8
Free pages:      90233 pages (-2135)
Pageins:         0 pages
Pageouts:        0 pages


Process:         appcode [25778]
Path:            /Applications/AppCode.app/Contents/MacOS/appcode
Architecture:    x86_64
Parent:          launchd [236]
UID:             501
Task size:       1375862 pages
CPU Time:        3.881s

0

I'd try to reset caches first with "File | Invalidate Caches/Restart...". Please also check if it can open some small test project.

0

Thanks Dmitrty that gave some progress:

Invalidating the cache and restarting gave the same result it tried to start indexing the entire local SSD.
I then opened a previous test project with 'this window' closing the project that was having the problem.  (Well every real xcode project I've tried had the problem.)
Invalidated the cache again, and this time it only indexed the one project and finished.
I then opened the real project again and it started going out of the directory of the project.


What portion of the workspace/project file can I look at to determine what it's trying to index?

0

Does your project contains symlinks that point outside project folder?

List of files to index is calculated on the fly so it's not enough to just look inside project structure. It would be great if you could send us .xcodeproj/.xcworkspace files of your project (and its subprojects) retaining directory structure to appcode-support@jetbrains.com. That way we could see what's happening with debugger. Is it possible?

0

Thanks for your response Dmitry, I have sent a 160k tar.gzip file generated from find . -type d -name "*xcodeproj" -or -name "*.xcworkspace" -exec tar cvzf forappcode.tar {} + in the main project folder of a test app that exhibits this behavior.  I suspect it may be a problem with one of the subprojects as the three main projects I've tried all exhibit the issue and all share common sub projects.

0

Please sign in to leave a comment.