Code completion lags

My problem is similar to the one described at http://devnet.jetbrains.com/message/5299711 , but I am not sure the suspected cause is the same--removing old virtual environments don't seem to affect performance.

Anyway, all is good except that for most of the 1.5 EAP downloads, and the 1.5.x releases, code completion really seems to slow down the editor.  I didn't seem to have this issue with the previous release (1.1?).

Is anyone else experiencing this issue?  Are there any "easy" fixes to try, like removing some cruft from the configuration directory or something?

Thanks,

Wayne

4 comments
Comment actions Permalink

Hello Wayne,

The best thing to do is not to guess, but rather to submit a CPU snapshot

as described in http://devnet.jetbrains.net/docs/DOC-1212

My problem is similar to the one described at

http://devnet.jetbrains.com/message/5299711 , but I am not sure the

suspected cause is the same--removing old virtual environments don't

seem to affect performance.

Anyway, all is good except that for most of the 1.5 EAP downloads, and

the 1.5.x releases, code completion really seems to slow down the

editor.  I didn't seem to have this issue with the previous release

(1.1?).

Is anyone else experiencing this issue?  Are there any "easy" fixes to

try, like removing some cruft from the configuration directory or

something?

--

Dmitry Jemerov

Development Lead

JetBrains, Inc.

http://www.jetbrains.com/

"Develop with Pleasure!"

0
Comment actions Permalink

Yeah, I kinda thought that would be the solution...;)

After I posted, I kept trying different things.  Doing this (http://www.jetbrains.com/pycharm/webhelp/smart-type-code-completion-completing-code-based-on-type-information.html) seemed to help immensely.

Doing so ( choosing Code | Complete Code | SmartType ) would seem to be a one-off setting, though.  In IDE Settings | Editor | Code Completion, there did not seem to be an option to set this for the entirety of the project.  Is there?  Does doing it via Code | Complete Code ... persist?

If it becomes a problem again, I will definitely send the CPU snapshot, but this really seems to be a configuration issue, and not one internal to PyCharm's code itself.

0
Comment actions Permalink

Hello Wayne,

Sorry, but I couldn't really understand what you mean. "SmartType" is not

a setting, it's an alternative code completion action which is used for Java

and some other languages. It doesn't do anything meaningful for Python code.

The only reason why it's present in PyCharm is because it is supported for

JavaScript. If you saw any difference in performance after invoking the action,

it's most likely just an accident.

Yeah, I kinda thought that would be the solution...;)

After I posted, I kept trying different things.  Doing this

(http://www.jetbrains.com/pycharm/webhelp/smart-type-code-completion-c

ompleting-code-based-on-type-information.html) seemed to help

immensely.

Doing so ( choosing Code | Complete Code | SmartType ) would seem to

be a one-off setting, though.  In IDE Settings | Editor | Code

Completion, there did not seem to be an option to set this for the

entirety of the project.  Is there?  Does doing it via Code | Complete

Code ... persist?

If it becomes a problem again, I will definitely send the CPU

snapshot, but this really seems to be a configuration issue, and not

one internal to PyCharm's code itself.

--

Dmitry Jemerov

Development Lead

JetBrains, Inc.

http://www.jetbrains.com/

"Develop with Pleasure!"

0
Comment actions Permalink

yole wrote:

Hello Wayne,

Sorry, but I couldn't really understand what you mean. "SmartType" is not

a setting, it's an alternative code completion action ...

This is what I was trying to describe, but didn't do a good job of. 

Like you mention, it seems to be an accident, but was a persitent problem for the last few weeks, which is kind of odd.

Anyway, I appreciate your help and like I said, if the issue arises again, I will follow the CPU snapshot instructions.

Thanks!

0

Please sign in to leave a comment.