AppCode 2.5 loses availability of LLDB until OS X upgrade?

I recently "upgraded" from the previous version of AppCode, to the latest version 2.5
Generally, when one thinks of an Upgrade, they probably consider one definition of that to mean "you get everything you had before, and then some"

I noticed in the debugger that it was set to GDB, and when I tried to change it to LLDB, it says I have to upgrade to a later OS X.
I have OS X 10.7.5

Why do I need a later OS X now in order to use LLDB?

2 comments

Joe, it's because the latest LLDB framework is only compatible with OS X 10.8.
GDB functionality on OS X 10.7 is comparable with that of LLDB so you should not miss LLDB much. Anyway, please let us know if you find any issues with it.

What are the reasons you don't upgrade to the latest OS X?

0

I considered upgrading OS X, but at the moment im in the middle of a really important project, and I can't afford any delays or issues that may crop up with a full operating system installation.
I will upgrade OS X later after I'm done with my current project.

0

Please sign in to leave a comment.