How to enable Restructured Text -> Docutils menu?

Context:

OS: Ubuntu 11.04 32 bit

Sun Jvm 1.6.0.24

PyCharm 1.5.3

installed packages (among others):

python2.7

python-docutils

python-sphinx

Hello,

I'd like to use Tools -> Restructured Text -> Docutils menu in some of my projects, you can see an example at http://ducktypes.franzoni.eu to see if anything is wrong.

doc type is set to restructured text, rst directory is set (although I'm not sure if it's for sphinx or for rest), but whatever I do, whenever I select a .rst file, the "Docutils" menu is grayed out.

On the contrary I'm perfectly able to run Sphinx actions.

From the command line, I'm able to run those commands which are in my path:

rst2html            rst2newlatex        rst2pseudoxml

rst2latex           rst2odt             rst2s5

rst2man             rst2odt_prepstyles  rst2xml

And my configured python interpreter can import the "docutils" module (pycharm recognizes it as well).
What should I do to let PyCharm recognize docutils tools? I tried searching the help but it just says to have docutils and sphinx installed for their respective functionality to be working, and they already are.
3 comments
Comment actions Permalink

Hi Alan,

have you tried to restart PyCharm?

PyCharm's trying to find rst2html.py script in standart interpreter and I don't see any reason why docutil is disabled.

0
Comment actions Permalink

Catherine,

bingo!

PyCharm seems to look for a file named rst2html.py , while Ubuntu just offers rst2html as a stock functionality.

Symlinking just made everything suddenly work.

Now I'll check the default behaviour for stock Python builds and maybe open a ticket if I feel it's a bug.

0
Comment actions Permalink

I have the same problem. I fixed by starting pycharm from the terminal with these vars set: 

 

export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8

0

Please sign in to leave a comment.