iOS: Confusion about running on device

I have 2 ios projects, one that was started before xcode5 came out. Another I started today (created it in xcode).

The former has options to run on my phone, as well as 4 simulators.
Screen Shot 2013-10-02 at 4.10.23 PM.png


The latter has options to run on 2 simulators.
Screen Shot 2013-10-02 at 4.10.38 PM.png

How can I tell Appcode to run it on my phone? "Edit Configurations" does not show anything related to this.
Also, xcode shows me simulators that are defined by their size, how do I choose these in Appcode?

3 comments
Comment actions Permalink

Hos,

AppCode offers only suitable simulators for the selected target, basing on the iOS Deployment Target build setting and target architecture.
The new project you've created most likely has iOS Deployment Target = 7.0 (default in Xcode 5)

0
Comment actions Permalink

I'm seeing this too. AppCode 2.1.2 doesn't seem to be able to run on the device if you have 64-bit enabled in your target architectures. Your new Xcode project likely has build settings for "Standard architectures (including 64-bit) (armv7, armv7s, arm64)". When I toggle that back to "Standard architectures (armv7, armv7s)", AppCode can run it on the device.

0
Comment actions Permalink

AppCode 2.1.x currently doesn't support Xcode 5.
We are preparing AppCode 2.5 release that will be available in a week. You can try the latest EAP build here.

0

Please sign in to leave a comment.