AppCode runs old build

I'm having a problem with AppCode that I can't figure out. Everything used to work fine until yesterday. Both things happen on the current release, and on the new EAP.

I have a solution that opens in AppCode and it builds properly. Everything works as expected, as you would imagine; making the code invalid and building throws errors, etc.

When I run the app in the simulator, though, an old version of the app starts up. I know it's an old version because it has old strings that are not even available on the app anymore. Also, even a simple NSLog() call added to the AppDelegate doesn't show up. The debugger properly connects to the app, but breakpoints obviously don't stop at the proper places.

In XCode, everything runs properly, including running in the simulator. I have already tried resetting the simulator, deleting all the Simulator files under ~/Library/Application Support, and AppCode->Invalidate Caches. I have also removed all Derived Data in XCode.

In summary, I have no idea where the current app being executed comes from. Would anybody have any idea?

1 comment

Please sign in to leave a comment.