Status of AppCode and XCode 5/IOS 7

Hi -

Are there any problems with me upgrading XCode to version 5? I'm looking to start iOS 7 testing, but don't want to break my current environment.

Thanks!

Dave

1 comment

In fact there are.

iOS7 SDK is supported OK, Xcode5 also is supported. But debugging is ... well, not so much. LLDB was updated in Xcode5, and current AppCode version still uses old one (from Xcode 4). So many things work not as well as they need to (evaluation, showing property values, etc.). Even if you replace bundled LLDB with one from Xcode, there still will be problems.

But, anyway, I develop iOS7 apps right now and AppCode still does most of it's job well as usual.

0

Please sign in to leave a comment.