Xcode 5 - Storyboards will not compile

I have a project I am building in Xcode 5. The Storyboard is set up for Xcode 5 only. The app will not compile in AppCode. I get this error:

The document "MainStoryboard.storyboard" could not be opened. Could not read archive.

Is there a work around to this other then setting the Storyboards "Opens In" to Xcode 4.6? I would like to keep it set to "Opens In" Xcode 5 so that I can use the new storyboard features.  Right now I have to change that setting to run in AppCode, then I revert the storyboard with Git before checking in code.

Thanks,

--Jason

2 comments

Jason,
you need to select the default Xcode so AppCode uses the correct one. Please see AppCode | Preferences | Xcode page for more details.

0

Hi Anton,
That is exactly what I needed. Thank you very much for the reply.  The command I ran was:
sudo xcode-select -switch /Applications/Xcode5-DP5.app/Contents/Developer

I had to delete my DerivedData in addition to restarting Xcode:
/Users/<user_name>/Library/Caches/appCode20/DerivedData

Thanks!
0

Please sign in to leave a comment.