Selected device is armv6 and cannot run any of available architectures: armv7, armv7s

Hi, 3 Days ago I had a dialog box pop up in AppCode where it asked me what architecture my iPhone was and I accidentally clicked on the wrong selection (armv6).
Now when i try to debug on my iPhone I get this error: Selected device is armv6 and cannot run any of available architectures: armv7, armv7s

I have no problem doing this in XCode but I don't really want to use XCode for this.

Does anybody know how to revert this setting?

Thanks in advance,

Emilio

3 comments

I decided to re-install AppCode 2.1.2 and I manged to get that same dialog box pop up. After I made the proper selection an error log was sent to JetBrains as well.
Seems like my iPhone 3GS (yes it is old but it still works 100%) has an issue with this version of AppCode.

I can now debug on my iPhone again... yeah!

0

Emilio,

you're able to change architecture in Project Setting.

0

Thanks for the report, Emilio,
if next time you accidentally choose wrong architecture, you'll be able to delete the wrong entry in ~/Library/Preferences/appCode20/other/AMDeviceDatabase.xml file.

0

Please sign in to leave a comment.