How to disable completely audible beeps?

Hi,

I am using the IdeaVim plugin. When I am in normal mode and I press the Esc key, there is a very annoying audible beep. How can I disable all beeps please?

13 comments

You should put "set visualbell" to your ~/.vimrc file, see ":help visualbell".

0

This doesn't seem to work. I disabled all beeps in vim and they are still there in AppCode...

0

Check that IdeaVim has found and parsed your .vimrc. Run ":set" in the normal mode, you should see "visualbell" there if it's set. Try ":set visualbell" in the normal mode. It should work for the current session.

0

If I disable the bell from within AppCode it works, but just for the session. If I close AppCode and reopen it it doesn't work. And I am sure that IdeaVim doesn't load my .vimrc file...

0

What's your OS and where is your .vimrc located on the file system?

0

I am using OS X Mountain Lion and my .vimrc is in my home directory (~)

0

Please paste an excerpt from your .vimrc where you define 'visualbell'.

0

autocmd VimEnter * set visualbell t_vb=

But again, I am pretty sure that IdeaVim doesn't parse my .vimrc

0

Why do you think so? Try setting hlsearch or ignorecase in .vimrc, for example. You should see them in the output of ":set".

Also note that IdeaVim is able to process only the top-level 'set' declarations in .vimrc.

0

I tried to add `set visualbell t_vb=` to the vimrc (in addition to the autocmd) but that didn't do the trick..

Also non of the stuff that I have in my vimrc is picked up by IdeaVim.

PS: I use janus

0

Actually you should put exactly this text on a single line:

set visualbell


because many syntax constructs are not supported.

(If you are interested in the .vimrc parsing details, here is the source code).

0

As of IdeaVIM 0.35, the rc file is now ~/.ideavimrc.

Put 

set visualbell
set noerrorbells

in ~/.ideavimrc 

0

Please sign in to leave a comment.