How to use Pinax in PyCharm?

I have done this:

"virtualenv is now supported (to configure, go to Settings | Python Interpreter, click Add, and select the python script inside the Scripts subdirectory of your virtualenv directory);

refers to the file ~/.virtualenv/project/bin/python
You can add the interpreter in global settings, but leave the main interpreter selected, and then go into Run | Edit Configurations to specify the specific interpreter for your project."
yet I still cannot run manage.py tasks under tools as it is disabled. Does anybody know why?

2 comments

Hello jesse,

In order for "run manage.py" to be enabled, the interpreter selected for

the project in Settings | Python Interpreters (not in a run configuration)

needs to have Django installed.

I have done this:

"virtualenv is now supported (to configure, go to Settings | Python

Interpreter, click Add, and select the python script inside the

Scripts subdirectory of your virtualenv directory);

refers to the file ~/.virtualenv/project/bin/python

You can add the interpreter in global settings, but leave the main

interpreter selected, and then go into Run | Edit Configurations to

specify the specific interpreter for your project."

yet I still cannot run manage.py tasks under tools as it is disabled.

Does anybody know why?

--

Dmitry Jemerov

Development Lead

JetBrains, Inc.

http://www.jetbrains.com/

"Develop with Pleasure!"

0

The environment has django installed, under site packages. I must be doing something wrong, manage.py remains disabled.

(social-env)jess-man@jessman:~$ python

Python 2.7.1+ (r271:86832, Apr 11 2011, 18:05:24)

[GCC 4.5.2] on linux2

Type "help", "copyright", "credits" or "license" for more information.

>>> import django

>>>

django looks to be imported from the environment.
0

Please sign in to leave a comment.