How to run Kiwi tests in AppCode?

               Hi there

I have been setting up the kiwi framework for pretty big amount of time according to this Getting Started Guide Eventually I was able to run my Kiwi test from XCode. I was forced using project.xcworkspace instead of project.xcodeproj file with XCode.
When I tried to run the same kiwi test in AppCode I got the following error:

Ld /Users/Dmitry/Library/Caches/appCode20/DerivedData/catandmouse-65c19164/Build/Products/Debug-iphonesimulator/projtest.octest/projtest normal i386
    cd /Users/Dmitry/Projects/ios/proto/catandmouse
    setenv PATH "/Applications/"
    /Applications/ -arch i386 -bundle -isysroot /Applications/ -L/Users/Dmitry/Library/Caches/appCode20/DerivedData/catandmouse-65c19164/Build/Products/Debug-iphonesimulator -F/Users/Dmitry/Library/Caches/appCode20/DerivedData/catandmouse-65c19164/Build/Products/Debug-iphonesimulator -F/Applications/ -F/Applications/ -filelist /Users/Dmitry/Library/Caches/appCode20/DerivedData/catandmouse-65c19164/Build/Intermediates/ -bundle_loader /Users/Dmitry/Library/Caches/appCode20/DerivedData/catandmouse-65c19164/Build/Products/Debug-iphonesimulator/ -Xlinker -objc_abi_version -Xlinker 2 -ObjC -framework SenTestingKit -fobjc-arc -fobjc-link-runtime -Xlinker -no_implicit_dylibs -mios-simulator-version-min=6.1 -framework SenTestingKit -framework UIKit -framework Foundation -lPods-projtest -o /Users/Dmitry/Library/Caches/appCode20/DerivedData/catandmouse-65c19164/Build/Products/Debug-iphonesimulator/projtest.octest/projtest

ld: library not found for -lPods-projtest
clang: error: linker command failed with exit code 1 (use -v to see invocation)

AppCode doesn't open .xcworkspace files. So how can I run my kiwi tests in AppCode?

Comment actions Permalink

You need to open the *.xcworkspace file in AppCode, not *.xcodeproj

Comment actions Permalink

It seems I was trying to open the workspace in AppCode in a wrong way. Opening it with Finder helped.


Please sign in to leave a comment.