No suspicious code found

Updated to 2.0.1 on a large project I and getting and immediate "No suspicious code found" and nothing reported.

When I right click any .m file and do Inspect Code... and look at the file I do get all kinds of reports.


I just cannot get the report on the complete project.

What do I need to do to make it work on a large project ?

This project has git submodules.

It worked for me on a small project without git submodules.

3 comments

Steve, please provide some details on the problem.

0

When I try Code, Inspect code, whole project on a complex project nothing happens. Immeatly retuens no supecious code found. If I do inspect code directory ... it will chew into the fiels an report  a lot of information.  

I got inspect whole proect to work on simple projects.

The comple project has mutiple targets, git submodules.

I can live with the directory report since it semms to cover eveything and I do not have to go file by file, but it seemed like whole project should have worked.

0

Steve, we can't reproduce the problem, we need your project. If you can't send it to us, you may shrink it (duplicate it and remove all the files except some files where inspections trigger). We'll appreciate if you create an issue in our tracker - http://youtrack.jetbrains.com/issues/OC

0

Please sign in to leave a comment.