2 comments
Comment actions Permalink

Guest wrote:

I'm trying to exclude a file from my project (a .gitignore file) but it always shows up in the project tree. Am I doing something wrong? The exact filename is in the Ignored Files settings.

Image:why.png

---

Original message URL: http://devnet.jetbrains.net/message/5445270#5445270

Hi Matt,

I don't think this is a Windows issue, as I have both PyCharn 1.5.4 plus the latest 2.0 Beta running on Windows 7 Pro 64-bit and am successfully ignoring lots of file --- though I am doing patterns not explicit filenames.

Basically all I did was go to File \ Settings \ IDE Settings \ File Types and append a couple more patterns to the default pattern.

So I had this:


CVS;SCCS;RCS;rcs;.DS_Store;.svn;.pyc;.pyo;*.pyc;*.pyo;.git;*.hprof;_svn;.hg;*.lib;*~;__pycache__;.bundle;

And I changed it to this:


CVS;SCCS;RCS;rcs;.DS_Store;.svn;.pyc;.pyo;*.pyc;*.pyo;.git;*.hprof;_svn;.hg;*.lib;*~;__pycache__;.bundle;*_py_output*;*_py_summary_*;

Explicitly listing a file should work (unless you have a typo :-) )  but perhaps appending either the *.gitignore; or .gitignor* pattern will solve your problem?

By the way, the link you posted dead ends for me and the image references does not render --- so it is hard to know exactly what you entered!

Cheers,

Rob

0
Comment actions Permalink

Wow, somehow I made a double-post.  This edit should make things cleaner.

0

Please sign in to leave a comment.