Configuring mako template highlighting: Template languages empty

Hello all,

I'm newbie to this ide and python. Iwas reading the docs for allowing hightlighting code for mako templates, but when I go to the template languages I don't find any installed with "nothing to show" message.

In fact, when I try to open a mako template pycharm treat it as a txt file and no mako file type defined in "Settings\File Types"

Do you know what I'm doing wrong?

Using pycharm 2.0.1 in ubuntu 11.10.

regards.

6 comments

The template language is actually selected in the "Template language" combobox, which is never empty. If your templates have a .mako extension, you need to map this extension to HTML file type in Settings | File Types.

0

I have the combobox empty. Pehaps something in the installation have gone awfull...I'll reinstall another time and this time in the mac.

0

Ah, now it's done.

Thanks for the tip.

0

What if the templates have a .mak extension? Is there a way to configure PyCharm to recognize and highlight them as Mako templates?

0

Yes. Map this extension to the HTML file type in Settings | File Types.

0

Thanks - it was unclear that the File type to modify should be HTML (although it makes sense). A mention of it in the docs would be wonderful.

Thanks!

0

Please sign in to leave a comment.