[solved] How to change the mercurial author in pycharm?

hi there,

when i want to commit some changes in my mercurial project - pycharm throws an error:

transaction abort!

rollback completed

abort: decoding near 'tephan Groß <sgross': 'ascii' codec can't decode byte 0xc3 in position 11: ordinal not in range(128)!

it seems like mercurial don't support uft-8 (ide is set to utf-8).
my last name contains a non ascii character "ß" which throws the problem.
so.. the best / easiest solution for me is to change the "author" field.
but where can i do this?
seems like pycharm magic cause i never typed it in and don't find it in the preferences.
so it must be some sort of system reading (btw mac osx - pycharm 2.0.2).
so i changed my system name (now without "ß") and removed all pycharm files within /Library/..
-- restart --
everything is clean but the author is still the same.
someone got a solution?
thanks
stephan
1 comment
Comment actions Permalink

problem solved.

Serge Baranov from JetBrains gave me the right hint. (thanks!)

you have edit your ".hgrc" file in your home directory.

there you will find your "username" which in my case included the non ascii char.

changed that - now running without any problems.

best stephan

0

Please sign in to leave a comment.