Why is 'Find Usages' less effective than a text search?

If I right-click on a method name and select 'Find Usages' (scope 'project files)I see two uses - both within the script containing the method. If I go to Edit->Find->Find in Path I see all 5 or so uses in the project.

Am I missing something?



Comment actions Permalink

Is your project directory listed under the interpreter paths under Settings | Python Interpreters?

Comment actions Permalink

I had the same problem today.  Here is what helped.

After clicking find usages, it was selecting by default 'Module MyModule'. 

I clicked on the ... and added a new scope called "My Module" and seleted all the files

Using that new scope, it worked.

Then, I noticed the next time I went into Find Usage, that "Project Files" was the default instead of MyModule.

Project Files, worked as well.

Then, I removed the new scope I created above, project files was still the default, everything works fine now.

Good luck...


Please sign in to leave a comment.