How does one push to a remote repository (not GitHub, privately run server)

I have been trying to understand how to push my commits to a remote repos, but cant figure out how to configure it. I did configure the remote by hand (git command line), however when pushing, AppCode seems to push to the local project repo ! (ie do nothing at all after commits). I have to rake behind the push with either command line or a tool like source tree to ensure that the server-based remote is properly updated.

AppCode seems to forget to :


MrEvil:Battles yvesleborg$ git push -v BattlesOnServer


Am i missing some obscure configuration ?


-- just gor giggles , even xCode seems to be doing this right, and lord knows git is not its strong suit.

ps : version 1.6.3

10 comments
Comment actions Permalink

Hello Yves,

Could you please share your .git/config file?

0
Comment actions Permalink

[core]
      repositoryformatversion = 0
      filemode = true
      bare = false
      logallrefupdates = true
      ignorecase = true
[remote "BattlesOnServer"]
      url = ssh://git@dev.maxpowerstudios.com/mnt/home/git/MaxPower/Battles
      fetch = +refs/heads/*:refs/remotes/BattlesOnServer/*

0
Comment actions Permalink

It looks like you incorrectly have "mailto:" in the remote url, do you?

0
Comment actions Permalink

no, that is a display sugar coating feature of your blog software . here, with spaces added

s s h : / / g i t @ d e v . m a x p o w e r s t u d i o s . c o m / m n t / h o m e / g i t / M a x P o w e r / B a t t l e s


note that without any changes to the config file, if at shell i do by hand :


git push -v BattlesOnServer
Pushing to s s h : / / g i t @ d e v . m a x p o w e r s t u d i o s . c o m / m n t / h o m e / g i t / M a x P o w e r / B a t t l e s
g i t @ d e v . m a x p o w e r s t u d i o s . c o m / m n t / h o m e / g i t / M a x P o w e r / B a t t l e s 's password:

... enter password here ...

Counting objects: 34, done.
Delta compression using up to 8 threads.
Compressing objects: 100% (18/18), done.
Writing objects: 100% (18/18), 2.33 KiB, done.
Total 18 (delta 12), reused 0 (delta 0)
To  s s h : / / g i t @ d e v . m a x p o w e r s t u d i o s . c o m / m n t / h o m e / g i t / M a x P o w e r / B a t t l e s
   0a5be0c..6d26f27  master -> master
updating local tracking ref 'refs/remotes/BattlesOnServer/master'

0
Comment actions Permalink

So what exactly happens in AppCode when you try to push? Please describe the steps you perform in detail.

0
Comment actions Permalink

here

urghhh ... just figured out : i clicked on the checkbox prompting for a 'different' branch, CHANGED NOTHING !!! just clicked, and the push worked. That is totally counter intuitive.



Attachment(s):
Screen Shot 2012-12-06 at 9.10.12 AM.png
Screen Shot 2012-12-06 at 9.10.41 AM.png
Screen Shot 2012-12-06 at 9.12.25 AM.png
0
Comment actions Permalink

You don't have a tracking branch yet, so you have to select the checkbox at the bottom of the push dialog.
The tracking will be set automatically after it.

Or you may manually set up tracking for your branch in the command line or .git/config.

0
Comment actions Permalink

yes ... as i commented above, when i checked that box and pushed, AppCode added the tracking branch to the config file. However, as GUI goes, it sucks. Visually the tiny message at the top does not get my attention compared to the bottom part, where 1) the correct repo is selected and 2) the correct branch is also shown !!!! EVEN THOUGH the tiny message tells me i am not tracking a branch. When you have no tracking branch, the push button should not even be selectable ... grrrrr.

:) but thanks for your help, i would not have figured out until you prompted me to describe 'exactly' .... i saw the tiny message when doadding the spapshot here :)

0
Comment actions Permalink

I agree that the UI should be improved. There is a request about that in our tracker: http://youtrack.jetbrains.com/issue/IDEA-93310
We'll try to make it soon.

0
Comment actions Permalink

i guess if i was not so busy trying to get a product out-the-door, i could spend my life following youtrack ... but alas my priorities are not there. However, on the subject of priorities, i have the feeling that your AppCode team has been going off-course lately. Your backlog on bug fixing and improvements does not seem to justify putting so much emphasis on major releases (like a disaster 2.0 EAP). AppCode is becoming a 'has been' as far as i am concerned. Your product does not do basic stuff right (like editing code), yet you rush to push out garbage Apple dogma stuff in a new release. Thats pretty much bread and butter when you are trying to develop products no ? focus focus focus

thanks for the help anyways ... it is still not bad enough to push me back to the Xcode lottery of bugs.

0

Please sign in to leave a comment.