Two AppCode Newbie Questions - stop process & editor settings...

Hi AppCode users.  I don't take newbie questions lightly, but after my first two weeks of using AppCode and searching the web/discussions, there are two significant issues I haven't cracked, which should logically be two different posts, but since they're both of the newbie kind, I thought I'd combine them...

1) I cannot reliably kill a test run.  Stop and %F2 seem to merely pause the executable.  Recompiling and redebugging the app doesn't even suggest that there is an app running.  I am often shocked on exit to find as many as 26 instances of my test code running, or multiple instances of my code in debug mode.  This eventually locks up the system, and I have to Force Quit Appcode.  So my question:

-> How do you actually terminate a debug session such that it is gone?  Stop seems no different than Pause.

2) I have been trying to adjust my editor settings (such as use tabs) by using AppCode->Preferences->Editor settings, etc.  The problem is that my choices seem to only apply to one open source file, and even then, only for the duration that one source file is open.

-> How do you make global changes to editor preferences that will remain in effect for all files, at the very least, within a given project, if not permanently?


Thanks everyone.  It's taken a little bit to acclimate to AppCode, and all platforms have some issues / are missing some features, but over all, I think AppCode is trememdously more robust than XCode, and that's why I've switched.

Thanks to everyone for their help.
- Jeff Diamond

P.S. I'm using AppCode 1.6.2 on Snow Leopard (10.6.8)

6 comments

Hi AppCode folks.

I've gotten lots of reads, but no replies.  Is this because I'd do better to position this as two separate questions, or because no one else has experienced my issues?

Thanks for any comments, even something like, "Sorry - never happened to me, no idea."
- Jeff

0

Jeff,
we apologize for the delay with the response.

Can you give us specifics on the both problems?
1) what kind of appliction do you test (iOS/OS X), are the tests hosted or a separate bundle, what version of Xcode does AppCode use (see Preferences | Xcode).
2) What setting exactly do you change that behaves this way?

0

Thanks so much for the response, Anton.  I really love AppCode, which is why I'd like to get past a few quirks...

I'm a bit off the beaten path, because I'm still stuck using Snow Leopard (10.6.8) due to software compatibility issues.  This is one of the reasons I turned to AppCode - because XCode 4.2 was too unstable and buggy.  I'm using XCode 4.2 to develop OS-X C++ GUI-LESS (text/console) applications - I think XCode calls them utilities - but it's basically 100% straight C++ code - no OS code used beyond cstdlib.  In trying to stop my executable, I only know about the things labeled "stop", i.e., the square red button and Apple-F2.  Yet as mentioned, these don't reliably make the running code go away, which makes sense, since I still have a "resume" option...  Is there a way to make sure a run is killed without exiting AppCode?

In trying to change my editor preferences, I do it from the menu as Preferences->...  The most important to me right now is Code Style -> General, where it still shows the changes I made but doesn't apply them.  My "scheme" on top is set to "Project".  When I make changes to this (or Editor), I see the changes in the current active source code Window ONLY, but never anywhere else.  It always seems to reset back.

Right now, my most pressing goal is to use actual tab characters, set them to just 2 spaces, and to change the way braces and code auto indents -> most easily by turning off auto indenting.

Thanks for any advice.  I realize that large sections of code will now permanently have spaces instead of tabs in it, but that's only the NEW code I typed since starting AppCode.

- Jeff

0

Jeff,
what you change spaces to tabs (and other code style settings), you need to reformat the code - AppCode won't change the existing formatting automatically.

As for the test stopping - we couldn't yet reproduce the problem. Can you please file a bug report (http://youtrack.jetbrains.net/issues/OC) and we'll investigate it further.

0

Thanks again, Anton.

I realize the editor won't automatically reformat code.  But if I'm using tab characters, and I set it from 4 to 2 spaces in size, I'd expect that (1) when it displayed code with tabs, they'd be then 2 spaces in size - if not immediately, at least when I reopened them, and (2) when i'm typing new code and I hit a tab, it would enter a tab that was 2 spaces in size.  Instead, it still types the default of 4 space characters when I hit tab.  Despite opening preferences and seeing it set to use tabs / 2 spaces.  Similarly, when I tell it not to autoindent, I can tell if that's happening when I type new code.  So I think it's beyond question that the settings I'm changing are not going into effect project wide.

I'll file a bug report on the stop process error.

Thanks again for your help - still hoping for some insights on the settings.
- Jeff

0

Guys, a new update in the preferences situation.  It appears that my assessment of "changes apply only locally" may have been false -> currently, I'm finding that I can't make any changes take effect at all!  Which is certainly an easier concept to debug. :)  So it looks like originally I got the pref changes to work, and now they don't - specifically, the dialogs show my changes, but typing in the editor produces the default effects.

And again, just to reclarify the tabs comment -> if the source code still has tab characters in it, every time it is displayed it should obey the preferences for how many spaces wide a tab should look, correct?  That's how it works in XCode, Visual Studio, etc...

Thanks again for all your help,
- Jeff

0

Please sign in to leave a comment.