Indexing Every Time Target Device is Changed from x86 to ARM.

Version: AppCode 120.293

Every time the target output device (iOS device, iPhone Simulator, iPad Simulator) is changed from the configuration dropdown from a simulated device (x86) to a 'navtive' device (ARM) box the IDE goes through a "Building Index" process, which can be annoyingly time consuming. Is this necessary every time the device is changed? The real problem is that the IDE is useless during this time since the process invokes a modal dialog and the editor is no longer available.



Attachment(s):
Indexing.png
4 comments
Comment actions Permalink

I mispelled 'native'. You can't edit your posts, doh!  

Edit: Yes you can edit your posts, if they are reply posts.

0
Comment actions Permalink

Marc,

The indexing is required, since SDKs for Simulator and Device are different, and to get navigation and all stuff we need to use the correct one.
But we are aware of this issue and will address it in future.

0
Comment actions Permalink

There is a partial workaround for this annoying pause:
After you Run your application, you can pin its tab in Run: pane. After changing to other target or device and running it the new tab is created and from now you can execute the first or second tab without waiting. Of course you have to repeat it for Debug and source classes are in context of the last Configuration.

0
Comment actions Permalink

Nice one )
Here is a request for you to vote and watch: http://youtrack.jetbrains.com/issue/OC-4856.

0

Please sign in to leave a comment.