remove annoying notify help message

Will buy pycharm, i somebody tells me how to remove. help message

For example i had code:

PROJECT_DIR = settings.PROJECT_DIR + '/website/'

change = {'database' : 

call(["mysql", " %s < %s/skelet/base.sql" % (change['database'], PROJECT_DIR)])

and i'm thinking what code should i craete after 'database' :.

While i'm thinking and press some keys, very very annoying message show up near call(["mysql", " %s < %s/skelet/base.sql" % (change['database'], PROJECT_DIR)]) code line.

This message take my attention, and in fack i'm thinking about how to remove this message, not about my code.

I'm turn off all notify messages in edit settings, even autocompeletion. But this angry message still with me.

In attach - file with example of this message.

Pycharm version - 2.0.2.

Somebody, please, helps me !



Attachment(s):
2012-06-24-013342_1680x1050_scrot.png
5 comments
Comment actions Permalink

It's a feature.

An annoying one, but also a useful one.  Write your code fast enough and make no mistakes ever, and you'll never see the inspection popups.

0
Comment actions Permalink

vladka wrote:

I'm turn off all notify messages in edit settings, even autocompeletion. But this angry message still with me.

In attach - file with example of this message.

Pycharm version - 2.0.2.

Try adjusting the settings under (1) Project Settings \ Inspecttions and/or (2) IDE Settings \ Intentions to meet your needs.

When I first took PyCharm out for a "test drive" a couple years ago, I found some of those inspection and intention popups annoying too --- especially when I used a sngle quote string and got a pop-up suggesting double-quotes which ironically if I did convert to double-quotes would then get a pop-up suggesting single quotes.  Took a couple weeks of regular usage and tweaks to get rachet down those pop-ups so they were less frequent and much more meaningful..

Cheers,

Rob

0
Comment actions Permalink

Rob,

The popup to change the quote style is an intention action. It's not a recommendation; it's simply a shortcut to perform the editing operation if you need it. Don't feel obliged to use it.

0
Comment actions Permalink

It's a feature.

An annoying one, but also a useful one. 


Well, nevermind its a feature or not, its not so useful, and its more annoying, that useful.

It will be better to show one time popup message, and there time just color background will be fine.

And don't what to see it all the time.

Write your code fast enough and make no mistakes ever, and you'll never see the inspection popups.

You can also recommend to me use vim, for example, it will be solution of my problem too :-)

0
Comment actions Permalink

Try adjusting the settings under (1) Project Settings \ Inspecttions and/or (2) IDE Settings \ Intentions to meet your needs.

thank you. I see there are some settings maybe i just turn off this popup and all.

0

Please sign in to leave a comment.