inconsolata and mac osx lion 10.7.4, PyCharm 2.5.2

Hello,

got an odd problem that I cannot seem to solve.

PyCharm comes with the inconsolata font built in, i use this all the time, I then install the font into the system's font library to use in other apps, like terminal etc. Now, when you load PyCharm after this and load Preferences, IDE Settings, Colors & Fonts, Fonts, then show the Select New Font Dialog, fonts are scanned, you see a progress bar here, then the inconsolata font is displayed with wide spaces and in some instances each letter is represented as a square containing the letter A. Removing the system font, reload PyCharm and its back to normal.

I am at a loss with this, any ideas or tips would be gratefully received, or is there a way to stop PyCharm using system fonts ? or is this a bug, if so i can raise a bug report.

Cheers

Richard



Attachment(s):
system font removed.png
system font installed.png
1 comment
Comment actions Permalink
You can disable loading the system fonts by appending "ide.register.bundled.fonts=false" to your /Applications/PyCharm.app/bin/idea.properties file.

Source: http://youtrack.jetbrains.com/issue/IDEA-81614#comment=27-661327
0

Please sign in to leave a comment.